summaryrefslogtreecommitdiffstats
path: root/gis/pyshp
diff options
context:
space:
mode:
author ArTourter <artourter@gmail.com>2022-03-09 12:25:57 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 21:29:30 +0700
commit4064e9ea0b98bb9cac5f1544d2593db907884d4c (patch)
treeef62b0b9a26856b9da3bb7b766eb2ca8d6367277 /gis/pyshp
parent47807bee2e83df26afee1842fc6615e9c6b86ff3 (diff)
downloadslackbuilds-4064e9ea0b98bb9cac5f1544d2593db907884d4c.tar.gz
slackbuilds-4064e9ea0b98bb9cac5f1544d2593db907884d4c.tar.xz
gis/python3-pyshp: renamed from gis/pyshp
Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/pyshp')
-rw-r--r--gis/pyshp/README4
-rw-r--r--gis/pyshp/pyshp.SlackBuild98
-rw-r--r--gis/pyshp/pyshp.info10
-rw-r--r--gis/pyshp/slack-desc19
4 files changed, 0 insertions, 131 deletions
diff --git a/gis/pyshp/README b/gis/pyshp/README
deleted file mode 100644
index 47bdcfc2cc..0000000000
--- a/gis/pyshp/README
+++ /dev/null
@@ -1,4 +0,0 @@
-The pyshp library reads and writes ESRI Shapefiles in pure Python. You can read
-and write shp, shx, and dbf files with all types of geometry. Everything in the
-public ESRI shapefile specification is implemented. This library is compatible
-with Python versions 2.4 to 3.x.
diff --git a/gis/pyshp/pyshp.SlackBuild b/gis/pyshp/pyshp.SlackBuild
deleted file mode 100644
index af9c9a77fa..0000000000
--- a/gis/pyshp/pyshp.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pyshp
-
-# Copyright 2014-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2021 Gregory J. L. Tourte <artourter@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pyshp
-VERSION=${VERSION:-2.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- changelog.txt README.md LICENSE.TXT \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/pyshp/pyshp.info b/gis/pyshp/pyshp.info
deleted file mode 100644
index d82fc9b586..0000000000
--- a/gis/pyshp/pyshp.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyshp"
-VERSION="2.2.0"
-HOMEPAGE="https://github.com/GeospatialPython/pyshp"
-DOWNLOAD="https://github.com/GeospatialPython/pyshp/archive/2.2.0/pyshp-2.2.0.tar.gz"
-MD5SUM="c86bf7d61ab8eea82cc5069a51bebc32"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="ArTourter"
-EMAIL="artourter@gmail.com"
diff --git a/gis/pyshp/slack-desc b/gis/pyshp/slack-desc
deleted file mode 100644
index a3ac9c6b9e..0000000000
--- a/gis/pyshp/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyshp: pyshp (Python shapefile manipulation library)
-pyshp:
-pyshp: This library reads and writes ESRI Shapefiles in pure Python. You can
-pyshp: read and write shp, shx, and dbf files with all types of geometry.
-pyshp: Everything in the public ESRI shapefile specification is implemented.
-pyshp: This library is compatible with Python versions 2.4 to 3.x.
-pyshp:
-pyshp:
-pyshp:
-pyshp:
-pyshp: