summaryrefslogtreecommitdiffstats
path: root/gis/python-mapnik
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-03-16 23:38:44 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-24 06:50:34 +0700
commitea631b6f20fddc60c91fe7e25267df1f9b6fe0df (patch)
treec8759f4644046b30928d5d0d89ffc93ef9c8d840 /gis/python-mapnik
parent703b90d4a385e6c7dd09b4bfa0b73b7deaecaa29 (diff)
downloadslackbuilds-ea631b6f20fddc60c91fe7e25267df1f9b6fe0df.tar.gz
slackbuilds-ea631b6f20fddc60c91fe7e25267df1f9b6fe0df.tar.xz
gis/python-mapnik: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'gis/python-mapnik')
-rw-r--r--gis/python-mapnik/python-mapnik.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/gis/python-mapnik/python-mapnik.SlackBuild b/gis/python-mapnik/python-mapnik.SlackBuild
index e5415af114..5a54a13d52 100644
--- a/gis/python-mapnik/python-mapnik.SlackBuild
+++ b/gis/python-mapnik/python-mapnik.SlackBuild
@@ -69,6 +69,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true