summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-03-16 22:59:24 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-24 06:50:33 +0700
commitcc68fd856c32af9b13e6130be7616ab991c9e99d (patch)
tree15377b9f34d78ab84a7c83992605259c2475ce48 /gis
parente7d7741c742782e3e4ce1424a631ebb4ec515f0e (diff)
downloadslackbuilds-cc68fd856c32af9b13e6130be7616ab991c9e99d.tar.gz
slackbuilds-cc68fd856c32af9b13e6130be7616ab991c9e99d.tar.xz
gis/polyline: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'gis')
-rw-r--r--gis/polyline/polyline.SlackBuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/gis/polyline/polyline.SlackBuild b/gis/polyline/polyline.SlackBuild
index 608c9ef842..7d549a3546 100644
--- a/gis/polyline/polyline.SlackBuild
+++ b/gis/polyline/polyline.SlackBuild
@@ -60,23 +60,24 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-if [ -e $CWD/v$VERSION.tar.gz ]; then
- tar xvf $CWD/v$VERSION.tar.gz
-else
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-fi
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install