summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-06-05 13:32:37 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-06-06 07:56:17 +0700
commit324db3ffdda3a2a13c83e1bc240c1ea7cab4c6ca (patch)
treece30ac2a728159f1f85d2eaec96c64a6fad38338 /gis
parent5a5b2238dc408fa54b0fe9761c34793df4daa478 (diff)
downloadslackbuilds-324db3ffdda3a2a13c83e1bc240c1ea7cab4c6ca.tar.gz
slackbuilds-324db3ffdda3a2a13c83e1bc240c1ea7cab4c6ca.tar.xz
gis/python-mapnik: Added (Python bindings for Mapnik).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/python-mapnik/README2
-rw-r--r--gis/python-mapnik/python-mapnik.SlackBuild86
-rw-r--r--gis/python-mapnik/python-mapnik.info10
-rw-r--r--gis/python-mapnik/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/gis/python-mapnik/README b/gis/python-mapnik/README
new file mode 100644
index 0000000000..b39f8c7a95
--- /dev/null
+++ b/gis/python-mapnik/README
@@ -0,0 +1,2 @@
+Mapnik is a free toolkit for developing mapping applications.
+The python-mapnik package provides the Python bindings for Mapnik.
diff --git a/gis/python-mapnik/python-mapnik.SlackBuild b/gis/python-mapnik/python-mapnik.SlackBuild
new file mode 100644
index 0000000000..16bb9e8d8f
--- /dev/null
+++ b/gis/python-mapnik/python-mapnik.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+#
+# SlackBuild for python-mapnik
+#
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-mapnik
+VERSION=${VERSION:-3.0.13}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xzf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS.md CHANGELOG.md COPYING README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/python-mapnik/python-mapnik.info b/gis/python-mapnik/python-mapnik.info
new file mode 100644
index 0000000000..eda1d3ffb0
--- /dev/null
+++ b/gis/python-mapnik/python-mapnik.info
@@ -0,0 +1,10 @@
+PRGNAM="python-mapnik"
+VERSION="3.0.13"
+HOMEPAGE="http://mapnik.org"
+DOWNLOAD="https://github.com/mapnik/python-mapnik/archive/v3.0.13/python-mapnik-3.0.13.tar.gz"
+MD5SUM="77b5d7dbbc30a8f43e02f4407063e96d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mapnik"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/python-mapnik/slack-desc b/gis/python-mapnik/slack-desc
new file mode 100644
index 0000000000..53d5788467
--- /dev/null
+++ b/gis/python-mapnik/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-mapnik: python-mapnik (Python bindings for Mapnik)
+python-mapnik:
+python-mapnik: Mapnik is an open source toolkit for rendering maps. This package
+python-mapnik: provides Python bindings for Mapnik.
+python-mapnik:
+python-mapnik:
+python-mapnik:
+python-mapnik:
+python-mapnik:
+python-mapnik:
+python-mapnik: