summaryrefslogtreecommitdiffstats
path: root/graphics/dia/dia.SlackBuild
diff options
context:
space:
mode:
author Philip Lacroix <slackph at posteo dot de>2015-09-19 19:44:25 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-19 19:44:25 +0700
commita5ef237349ea8ac445a898ae72ef48079632c2e2 (patch)
tree8557f3abfd4ac9add242288da997e517143964a9 /graphics/dia/dia.SlackBuild
parente52bc22392ac81d21bb96e0cdb4334b9f8274dea (diff)
downloadslackbuilds-a5ef237349ea8ac445a898ae72ef48079632c2e2.tar.gz
slackbuilds-a5ef237349ea8ac445a898ae72ef48079632c2e2.tar.xz
graphics/dia: Updated for version 0.97.3 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/dia/dia.SlackBuild')
-rw-r--r--graphics/dia/dia.SlackBuild43
1 files changed, 23 insertions, 20 deletions
diff --git a/graphics/dia/dia.SlackBuild b/graphics/dia/dia.SlackBuild
index 0ac1d62b6b..3eacc8ad4d 100644
--- a/graphics/dia/dia.SlackBuild
+++ b/graphics/dia/dia.SlackBuild
@@ -1,13 +1,15 @@
#!/bin/sh
# Slackware build script for dia
-# Written by Matt Hayes (dominian@slackadelic.com
-# Updated for 64bit by Ash Wiren (ash@spooksoftware.com 19-08-2009
-# Currently mantained by Dugan Chen (thedoogster@gmail.com)))
+
+# Originally written by Matt Hayes <dominian at slackadelic dot com>
+# Updated for 64bit by Ash Wiren <ash at spooksoftware dot com> (19.08.2009)
+# Maintained by Dugan Chen <thedoogster at gmail dot com> (<= 18.09.2015)
+# Updated and currently maintained by Philip Lacroix <slackph at posteo dot de>
PRGNAM=dia
-VERSION=0.97.2
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-0.97.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -44,19 +46,15 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix the location of the French manpages.
-sed -i 's/$(datadir)\/man/@mandir@/' doc/fr/Makefile.in
-
-# apply patches from upstream
-for i in $CWD/patches/* ; do patch -p1 < $i ; done
autoreconf -fi
CFLAGS="$SLKCFLAGS" \
@@ -71,17 +69,22 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGMAN=$PKG/usr/man
+PRGSHR=$PKG/usr/share
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+# Move French man page to correct location; compress both.
+mv $PRGSHR/man/fr $PRGMAN/
+gzip -9 $PRGMAN/{,fr/}man1/$PRGNAM.1
+rmdir $PRGSHR/man
-# docdir already exists :-)
-cp -a \
- AUTHORS COPYING ChangeLog ChangeLog.pre-git KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Install documentation.
+cp -a AUTHORS COPYING ChangeLog* KNOWN_BUGS MAINTAINERS NEWS README \
+ \RELEASE-PROCESS THANKS TODO $PRGDOC/
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc