summaryrefslogtreecommitdiffstats
path: root/graphics/dia
diff options
context:
space:
mode:
author Philip Lacroix <slackph at posteo dot de>2015-10-11 14:50:22 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-10-11 15:00:41 +0700
commit5772615d861b23069534e1b1c6f3f8a01579d9cc (patch)
treec502c164445cd3a12236e5c582718bbf98889e98 /graphics/dia
parent2a9889a9b5f21cd8018aba92408bb53dd60c8db1 (diff)
downloadslackbuilds-5772615d861b23069534e1b1c6f3f8a01579d9cc.tar.gz
slackbuilds-5772615d861b23069534e1b1c6f3f8a01579d9cc.tar.xz
graphics/dia: Build HTML documentation.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/dia')
-rw-r--r--graphics/dia/dia-enable-html-docs.patch26
-rw-r--r--graphics/dia/dia.SlackBuild18
2 files changed, 43 insertions, 1 deletions
diff --git a/graphics/dia/dia-enable-html-docs.patch b/graphics/dia/dia-enable-html-docs.patch
new file mode 100644
index 0000000000..9bc02e1c0c
--- /dev/null
+++ b/graphics/dia/dia-enable-html-docs.patch
@@ -0,0 +1,26 @@
+diff -u a/configure.in b/configure.in
+--- a/configure.in 2015-10-10 20:23:14.257728818 +0200
++++ b/configure.in 2015-10-10 20:23:44.512728478 +0200
+@@ -532,10 +532,10 @@
+ AM_CONDITIONAL(WITH_JW, test "xno" != "xno")
+ fi
+ hardbook_ok=no
+-xsltproc_ok=no
++xsltproc_ok=yes
+ if test "x$with_hardbooks" = "xno"; then
+ AM_CONDITIONAL(WITH_JW, test "xno" != "xno")
+- AM_CONDITIONAL(WITH_HTMLDOC, test "xno" != "xno")
++ AM_CONDITIONAL(WITH_HTMLDOC, test "x$xsltproc" != "xno")
+ AM_CONDITIONAL(WITH_PDFDOC, test "xno" != "xno")
+ AM_CONDITIONAL(WITH_PSDOC, test "xno" != "xno")
+ else
+@@ -549,9 +549,6 @@
+ hardbook_ok=yes
+ fi
+ fi
+- if test "x$xsltproc" != "xno" ; then
+- xsltproc_ok=yes
+- fi
+ fi
+
+
diff --git a/graphics/dia/dia.SlackBuild b/graphics/dia/dia.SlackBuild
index 3eacc8ad4d..a3dd7b330c 100644
--- a/graphics/dia/dia.SlackBuild
+++ b/graphics/dia/dia.SlackBuild
@@ -5,11 +5,19 @@
# Originally written by Matt Hayes <dominian at slackadelic dot com>
# Updated for 64bit by Ash Wiren <ash at spooksoftware dot com> (19.08.2009)
# Maintained by Dugan Chen <thedoogster at gmail dot com> (<= 18.09.2015)
+#
# Updated and currently maintained by Philip Lacroix <slackph at posteo dot de>
+#
+# 19.09.2015:
+# - reviewed and updated for dia 0.97.3.
+# 10.10.2015:
+# - enabled HTML documentation (based on patch by Mike Gorse, SUSE);
+# - enabled python and cairo plug-ins, SWIG;
+# - disabled gnome code (deprecated).
PRGNAM=dia
VERSION=${VERSION:-0.97.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -55,6 +63,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Enable HTML documentation, necessary for online help functionality.
+patch configure.in < $CWD/dia-enable-html-docs.patch
+
autoreconf -fi
CFLAGS="$SLKCFLAGS" \
@@ -64,6 +75,11 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--docdir=/usr/doc/$PRGNAM-$VERSION \
+ --with-swig \
+ --with-cairo \
+ --with-python \
+ --disable-gnome \
+ --disable-static \
--build=$ARCH-slackware-linux
make