summaryrefslogtreecommitdiffstats
path: root/graphics/dia
diff options
context:
space:
mode:
author Philip Lacroix <slackph at posteo dot de>2017-02-09 21:26:46 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-11 07:24:32 +0700
commit706f1278c49da4f781f17f73c2a5da01b722b789 (patch)
tree5e0ad2c126d6c40f88e4a4b5e139986ea5ae8825 /graphics/dia
parenteecdc05446ace37bad0e484181749bcf5809834d (diff)
downloadslackbuilds-706f1278c49da4f781f17f73c2a5da01b722b789.tar.gz
slackbuilds-706f1278c49da4f781f17f73c2a5da01b722b789.tar.xz
graphics/dia: Switch to i586.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'graphics/dia')
-rw-r--r--graphics/dia/dia.SlackBuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/graphics/dia/dia.SlackBuild b/graphics/dia/dia.SlackBuild
index a3dd7b330c..0726d31766 100644
--- a/graphics/dia/dia.SlackBuild
+++ b/graphics/dia/dia.SlackBuild
@@ -3,17 +3,17 @@
# Slackware build script for dia
# Originally written by Matt Hayes <dominian at slackadelic dot com>
-# Updated for 64bit by Ash Wiren <ash at spooksoftware dot com> (19.08.2009)
-# Maintained by Dugan Chen <thedoogster at gmail dot com> (<= 18.09.2015)
+# Updated for 64bit by Ash Wiren <ash at spooksoftware dot com> (19.08.2009)
+# Maintained by Dugan Chen <thedoogster at gmail dot com> (<= 18.09.2015)
#
# Updated and currently maintained by Philip Lacroix <slackph at posteo dot de>
#
-# 19.09.2015:
-# - reviewed and updated for dia 0.97.3.
# 10.10.2015:
-# - enabled HTML documentation (based on patch by Mike Gorse, SUSE);
-# - enabled python and cairo plug-ins, SWIG;
-# - disabled gnome code (deprecated).
+# * enabled HTML documentation (based on patch by Mike Gorse, SUSE);
+# * enabled SWIG, Python and Cairo plug-ins;
+# * disabled Gnome code (deprecated).
+# 19.09.2015:
+# * reviewed and updated for dia 0.97.3.
PRGNAM=dia
VERSION=${VERSION:-0.97.3}
@@ -22,7 +22,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -33,8 +33,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -63,7 +63,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Enable HTML documentation, necessary for online help functionality.
+# Enable HTML documentation, necessary for Help functionality.
patch configure.in < $CWD/dia-enable-html-docs.patch
autoreconf -fi
@@ -92,7 +92,7 @@ PRGMAN=$PKG/usr/man
PRGSHR=$PKG/usr/share
PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-# Move French man page to correct location; compress both.
+# Move French man page to correct location; compress.
mv $PRGSHR/man/fr $PRGMAN/
gzip -9 $PRGMAN/{,fr/}man1/$PRGNAM.1
rmdir $PRGSHR/man