summaryrefslogtreecommitdiffstats
path: root/graphics/dia
diff options
context:
space:
mode:
author ponce <matteo.bernardini@gmail.com>2012-07-24 12:31:02 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-08-21 08:55:28 -0500
commitba69e24e69e88a9ebd6da2d12c3c77b65ce42de0 (patch)
treeff7f4d9ec64ec78c60049aeef558aa5274bbf035 /graphics/dia
parent434fe3357560bbb6df97e45cb3efbeeadb909164 (diff)
downloadslackbuilds-ba69e24e69e88a9ebd6da2d12c3c77b65ce42de0.tar.gz
slackbuilds-ba69e24e69e88a9ebd6da2d12c3c77b65ce42de0.tar.xz
graphics/dia: Included a patch for glib >= 2.31.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'graphics/dia')
-rw-r--r--graphics/dia/dia-0.97.2-glib-2.31.patch59
-rw-r--r--graphics/dia/dia.SlackBuild5
2 files changed, 63 insertions, 1 deletions
diff --git a/graphics/dia/dia-0.97.2-glib-2.31.patch b/graphics/dia/dia-0.97.2-glib-2.31.patch
new file mode 100644
index 0000000000..7429cd2177
--- /dev/null
+++ b/graphics/dia/dia-0.97.2-glib-2.31.patch
@@ -0,0 +1,59 @@
+From e3d41e6dd3488a29d23f53c57526871a9b79e9bf Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 7 Apr 2012 20:43:27 -0400
+Subject: [PATCH] Do not include glib subheaders directly
+
+Otherwise, dia cannot build against >=glib-2.31
+
+https://bugzilla.gnome.org/show_bug.cgi?id=673712
+---
+ objects/custom/shape_typeinfo.c | 2 +-
+ tests/test-boundingbox.c | 3 ---
+ tests/test-objects.c | 4 ----
+ 3 files changed, 1 insertions(+), 8 deletions(-)
+
+diff --git a/objects/custom/shape_typeinfo.c b/objects/custom/shape_typeinfo.c
+index c6133b1..3fb3d73 100644
+--- a/objects/custom/shape_typeinfo.c
++++ b/objects/custom/shape_typeinfo.c
+@@ -27,7 +27,7 @@
+ #include "custom_util.h"
+ #include <string.h>
+ #include <stdarg.h>
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <glib/gstdio.h>
+ #include <libxml/parser.h>
+
+diff --git a/tests/test-boundingbox.c b/tests/test-boundingbox.c
+index 7adaab5..a13d018 100644
+--- a/tests/test-boundingbox.c
++++ b/tests/test-boundingbox.c
+@@ -28,9 +28,6 @@
+ #include <glib.h>
+ #include <glib-object.h>
+
+-#if GLIB_CHECK_VERSION(2,16,0)
+-#include <glib/gtestutils.h>
+-#endif
+ #include "dialib.h"
+
+ /*
+diff --git a/tests/test-objects.c b/tests/test-objects.c
+index 57d5675..c5980a5 100644
+--- a/tests/test-objects.c
++++ b/tests/test-objects.c
+@@ -28,10 +28,6 @@
+ #include <glib.h>
+ #include <glib-object.h>
+
+-#if GLIB_CHECK_VERSION(2,16,0)
+-#include <glib/gtestutils.h>
+-#endif
+-
+ #include "object.h"
+ #include "plug-ins.h"
+ #include "dialib.h"
+--
+1.7.8.5
+
diff --git a/graphics/dia/dia.SlackBuild b/graphics/dia/dia.SlackBuild
index e12e86a37e..24b8b00626 100644
--- a/graphics/dia/dia.SlackBuild
+++ b/graphics/dia/dia.SlackBuild
@@ -7,7 +7,7 @@
PRGNAM=dia
VERSION=0.97.2
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -51,6 +51,9 @@ chmod -R u+w,go+r-w,a-s .
# Fix the location of the French manpages.
sed -i 's/$(datadir)\/man/@mandir@/' doc/fr/Makefile.in
+# patch for glib >= 2.31 (thanks gentoo people)
+patch -p1 < $CWD/dia-0.97.2-glib-2.31.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \