summaryrefslogtreecommitdiffstats
path: root/graphics/mcomix
diff options
context:
space:
mode:
author Jože Zobec <jozze.zepl@gmail.com>2012-12-20 12:22:49 +0100
committer Matteo Bernardini <ponce@slackbuilds.org>2012-12-20 12:23:04 +0100
commit345e3708999abdf98c8deb2c8ff6de49a5a4a81e (patch)
treebfaa25336b7a52cf6cc3a6f69630491286bf9684 /graphics/mcomix
parente524edc30cdab8b8cca5a3265c171c2d8ef941f6 (diff)
downloadslackbuilds-345e3708999abdf98c8deb2c8ff6de49a5a4a81e.tar.gz
slackbuilds-345e3708999abdf98c8deb2c8ff6de49a5a4a81e.tar.xz
graphics/mcomix: Added (comic book viewer).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'graphics/mcomix')
-rw-r--r--graphics/mcomix/README20
-rw-r--r--graphics/mcomix/mcomix.SlackBuild90
-rw-r--r--graphics/mcomix/mcomix.info10
-rw-r--r--graphics/mcomix/slack-desc18
4 files changed, 138 insertions, 0 deletions
diff --git a/graphics/mcomix/README b/graphics/mcomix/README
new file mode 100644
index 0000000000..e0a1b82185
--- /dev/null
+++ b/graphics/mcomix/README
@@ -0,0 +1,20 @@
+MComix - user-friendly, customizable image viewer for comic books
+
+MComix is a user-friendly, customizable image viewer. It is specifically
+designed to handle comic books, but also serves as a generic viewer. It
+reads images in ZIP, RAR, 7Zip or tar archives as well as plain image files. It
+is written in Python and uses GTK+ through the PyGTK bindings.
+
+MComix is a fork of the Comix project, and aims to add bug fixes and stability
+improvements after Comix development came to a halt in late 2009.
+
+OPTIONAL DEPENDENCIES:
+You also need either the "unrar" or the "rar" program installed if you wish
+to read RAR (.cbr) archives.
+
+Alternatively, MComix can be built over the optional dependency libunrar
+from Rarlab.
+
+To read 7Zip archives, you need to have the "7z" program installed. Likewise,
+"lha" is needed to open LHA/LZA archives. Note that "7z" can be used as
+substitute for both "unrar" and "lha".
diff --git a/graphics/mcomix/mcomix.SlackBuild b/graphics/mcomix/mcomix.SlackBuild
new file mode 100644
index 0000000000..e045a2a048
--- /dev/null
+++ b/graphics/mcomix/mcomix.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for MComix
+
+# written by Joze Zobec <jozze.zepl@gmail.com>
+
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=mcomix
+VERSION=${VERSION:-0.99}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+mkdir -p $PKG/usr
+
+python setup.py install --single-version-externally-managed \
+ --root=$PKG \
+ --prefix=/usr \
+ --record mcomix-files.txt
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/man
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README PKG-INFO COPYING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/mcomix/mcomix.info b/graphics/mcomix/mcomix.info
new file mode 100644
index 0000000000..1ee2c99409
--- /dev/null
+++ b/graphics/mcomix/mcomix.info
@@ -0,0 +1,10 @@
+PRGNAM="mcomix"
+VERSION="0.99"
+HOMEPAGE="http://mcomix.sourceforge.net"
+DOWNLOAD="http://downloads.sourceforge.net/mcomix/mcomix-0.99.tar.bz2"
+MD5SUM="a1ff7e1955042069d5005b4034e7a914"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="distribute"
+MAINTAINER="Jože Zobec"
+EMAIL="jozze.zepl@gmail.com"
diff --git a/graphics/mcomix/slack-desc b/graphics/mcomix/slack-desc
new file mode 100644
index 0000000000..7c968476cb
--- /dev/null
+++ b/graphics/mcomix/slack-desc
@@ -0,0 +1,18 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+mcomix: MComix - user-friendly, customizable image viewer for comic books
+mcomix:
+mcomix: MComix is a user-friendly, customizable image viewer. It is
+mcomix: specifically designed to handle comic books, but also serves as a
+mcomix: generic viewer. It reads images in ZIP, RAR, 7Zip or tar archives as
+mcomix: well as plain image files. It is written in Python and uses GTK+
+mcomix: through the PyGTK bindings.
+mcomix:
+mcomix: Homepage: mcomix.sourceforge.net
+mcomix: