summaryrefslogtreecommitdiffstats
path: root/graphics/mirage
diff options
context:
space:
mode:
author Frank Caraballo <fecaraballo{at}gmail{dot}com>2010-05-11 20:00:37 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-11 20:00:37 +0200
commitd2356febdc43936f115e6b0b8027f7d6d8e5b506 (patch)
tree39d8148dab6f0343187d7d97aaef8b0ad980cf75 /graphics/mirage
parentab1943dd08746f7c93f00734aab161b037376093 (diff)
downloadslackbuilds-d2356febdc43936f115e6b0b8027f7d6d8e5b506.tar.gz
slackbuilds-d2356febdc43936f115e6b0b8027f7d6d8e5b506.tar.xz
graphics/mirage: Added to 12.0 repository
Diffstat (limited to 'graphics/mirage')
-rw-r--r--graphics/mirage/README7
-rw-r--r--graphics/mirage/doinst.sh3
-rw-r--r--graphics/mirage/mirage.SlackBuild78
-rw-r--r--graphics/mirage/mirage.info8
-rw-r--r--graphics/mirage/slack-desc19
5 files changed, 115 insertions, 0 deletions
diff --git a/graphics/mirage/README b/graphics/mirage/README
new file mode 100644
index 0000000000..a1fb936d20
--- /dev/null
+++ b/graphics/mirage/README
@@ -0,0 +1,7 @@
+Mirage is a fast and simple GTK+ image viewer. Because
+it depends only on PyGTK, Mirage is ideal for users who
+wish to keep their computers lean while still having a
+clean image viewer.
+
+pygtk (also available at http://www.slackbuilds.org/) is
+required to build this package.
diff --git a/graphics/mirage/doinst.sh b/graphics/mirage/doinst.sh
new file mode 100644
index 0000000000..5dc6bb58c0
--- /dev/null
+++ b/graphics/mirage/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x usr/bin/update-desktop-database ]; then
+ usr/bin/update-desktop-database -q usr/share/applications
+fi
diff --git a/graphics/mirage/mirage.SlackBuild b/graphics/mirage/mirage.SlackBuild
new file mode 100644
index 0000000000..64d97fcdab
--- /dev/null
+++ b/graphics/mirage/mirage.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# Slackware build script for Mirage
+
+# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=mirage
+VERSION=0.9.2
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="CHANGELOG COPYING README TODO TRANSLATORS"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
+cd $PRGNAM-$VERSION || exit 1
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py build || exit 1
+python setup.py install --root $PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/graphics/mirage/mirage.info b/graphics/mirage/mirage.info
new file mode 100644
index 0000000000..c358014ac1
--- /dev/null
+++ b/graphics/mirage/mirage.info
@@ -0,0 +1,8 @@
+PRGNAM="mirage"
+VERSION="0.9.2"
+HOMEPAGE="http://mirageiv.berlios.de/"
+DOWNLOAD="http://download.berlios.de/mirageiv/mirage-0.9.2.tar.bz2"
+MD5SUM="cfa605ac69e683e5338800b12e5b6d5d"
+MAINTAINER="Frank Caraballo"
+EMAIL="fecaraballo{at}gmail{dot}com"
+APPROVED="David Somero"
diff --git a/graphics/mirage/slack-desc b/graphics/mirage/slack-desc
new file mode 100644
index 0000000000..f9da729cfe
--- /dev/null
+++ b/graphics/mirage/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+mirage: Mirage (GTK+ Image Viewer)
+mirage:
+mirage: Mirage is a fast and simple GTK+ image viewer. Because
+mirage: it depends only on PyGTK, Mirage is ideal for users who
+mirage: wish to keep their computers lean while still having a
+mirage: clean image viewer.
+mirage:
+mirage: Homepage: http://mirageiv.berlios.de/
+mirage:
+mirage:
+mirage: