summaryrefslogtreecommitdiffstats
path: root/graphics/nomacs
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2013-11-05 15:52:31 +0100
committer Robby Workman <rworkman@slackbuilds.org>2013-11-06 00:56:51 -0600
commit36b9d2ef47a33d7cfb19879dca67f3250a4c2b4e (patch)
tree5722d62223d06d743651291d47aff4a7a5016c3c /graphics/nomacs
parent4e9f1ae0907d8bed85549e4d197abaf3bbf90747 (diff)
downloadslackbuilds-36b9d2ef47a33d7cfb19879dca67f3250a4c2b4e.tar.gz
slackbuilds-36b9d2ef47a33d7cfb19879dca67f3250a4c2b4e.tar.xz
graphics/nomacs: Updated for version 1.6.0.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'graphics/nomacs')
-rw-r--r--graphics/nomacs/nomacs.SlackBuild13
-rw-r--r--graphics/nomacs/nomacs.info6
2 files changed, 12 insertions, 7 deletions
diff --git a/graphics/nomacs/nomacs.SlackBuild b/graphics/nomacs/nomacs.SlackBuild
index a78395ee8f..2ac80845c1 100644
--- a/graphics/nomacs/nomacs.SlackBuild
+++ b/graphics/nomacs/nomacs.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for nomacs
-# Copyright Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy, 2012
+# Copyright Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy, 2013
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=nomacs
-VERSION=${VERSION:-0.4.0}
+VERSION=${VERSION:-1.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,9 +61,8 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-mkdir $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION-source.tar.?z*
cd $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION-source.zip
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -71,6 +70,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix man pages installation path
+sed -i "s|share\/man|man|" CMakeLists.txt
+
mkdir -p build
cd build
cmake \
@@ -86,6 +88,9 @@ cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/graphics/nomacs/nomacs.info b/graphics/nomacs/nomacs.info
index fed12257bf..6af0d5fa4a 100644
--- a/graphics/nomacs/nomacs.info
+++ b/graphics/nomacs/nomacs.info
@@ -1,8 +1,8 @@
PRGNAM="nomacs"
-VERSION="0.4.0"
+VERSION="1.6.0"
HOMEPAGE="http://www.nomacs.org"
-DOWNLOAD="http://downloads.sourceforge.net/nomacs/nomacs-0.4.0-source.zip"
-MD5SUM="3ae8cf0da41ea10d41bdd33d41bd7282"
+DOWNLOAD="http://downloads.sourceforge.net/nomacs/nomacs-1.6.0-source.tar.bz2"
+MD5SUM="61cabef5638a4a2dabd0865df07e4b07"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="LibRaw opencv"