summaryrefslogtreecommitdiffstats
path: root/graphics/pygraphviz
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-27 00:55:50 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-29 06:58:15 +0700
commit1d7a8e940ea2348b09da412f6b589bdcbc5a58f6 (patch)
tree0f777653aeda47a6bc8cf25e439989a25aa2d19c /graphics/pygraphviz
parent7c74907c8fb0683f3ae58501df4ced3e66b35f51 (diff)
downloadslackbuilds-1d7a8e940ea2348b09da412f6b589bdcbc5a58f6.tar.gz
slackbuilds-1d7a8e940ea2348b09da412f6b589bdcbc5a58f6.tar.xz
graphics/pygraphviz: Add python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'graphics/pygraphviz')
-rw-r--r--graphics/pygraphviz/pygraphviz.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/graphics/pygraphviz/pygraphviz.SlackBuild b/graphics/pygraphviz/pygraphviz.SlackBuild
index 941ee9710e..e684e29734 100644
--- a/graphics/pygraphviz/pygraphviz.SlackBuild
+++ b/graphics/pygraphviz/pygraphviz.SlackBuild
@@ -74,6 +74,11 @@ sed -i "s/share\/doc/doc/" setup.py
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true