summaryrefslogtreecommitdiffstats
path: root/graphics/qcomicbook
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-04-18 16:41:43 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-22 11:38:36 +0700
commit2f6aa6fd9c9bad13cf74cab101c0be23808f34fd (patch)
tree474a815f8e503fd844acd233b1fd665bc2367171 /graphics/qcomicbook
parent77bc44d36d3a80e856089a0caaeb93e7a6d7e2e9 (diff)
downloadslackbuilds-2f6aa6fd9c9bad13cf74cab101c0be23808f34fd.tar.gz
slackbuilds-2f6aa6fd9c9bad13cf74cab101c0be23808f34fd.tar.xz
graphics/qcomicbook: New maintainer.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/qcomicbook')
-rw-r--r--graphics/qcomicbook/README20
-rw-r--r--graphics/qcomicbook/doinst.sh5
-rw-r--r--graphics/qcomicbook/qcomicbook.SlackBuild70
-rw-r--r--graphics/qcomicbook/qcomicbook.info6
-rw-r--r--graphics/qcomicbook/slack-desc14
5 files changed, 72 insertions, 43 deletions
diff --git a/graphics/qcomicbook/README b/graphics/qcomicbook/README
index a4d1ff82ff..faf2052b14 100644
--- a/graphics/qcomicbook/README
+++ b/graphics/qcomicbook/README
@@ -1,5 +1,17 @@
-QComicBook (Comic Book Reader)
+qcomicbook (comic book reader)
-QComicBook is a graphical application that allows sequential display of
-archived (zip or rar) images, a well known technique for distributing
-digital copies of comic books.
+QComicBook is a viewer for PDF files and comic book archives
+containing jpeg/png/xpm/gif/bmp images, which aims at convenience
+and simplicity. Features include: automatic unpacking of archive
+files, full-screen mode, continuous scrolling mode, double-pages
+viewing, manga mode, thumbnails view, page scaling, mouse or keyboard
+navigation etc.
+
+Optional, but highly recommended:
+
+unrar - required for .cbr files.
+p7zip - required for .cb7 files.
+unace - required for .cba files (which are pretty rare).
+
+These are runtime dependencies; you don't have to rebuild qcomicbook
+after installing them.
diff --git a/graphics/qcomicbook/doinst.sh b/graphics/qcomicbook/doinst.sh
index 4e8ba7071d..3e5691a052 100644
--- a/graphics/qcomicbook/doinst.sh
+++ b/graphics/qcomicbook/doinst.sh
@@ -2,3 +2,8 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/graphics/qcomicbook/qcomicbook.SlackBuild b/graphics/qcomicbook/qcomicbook.SlackBuild
index c863fb1248..eada94d7a0 100644
--- a/graphics/qcomicbook/qcomicbook.SlackBuild
+++ b/graphics/qcomicbook/qcomicbook.SlackBuild
@@ -3,9 +3,10 @@
# Slackware build script for QComicBook:
# a program to visualize digitalized comic books
-# Original version written by Amiralul - tanaselia@gmail.com
+# Original version written by Amiralul (email removed)
# Copyright 2009-2012 Niels Horn, Rio de Janeiro, RJ, Brazil
+# Copyright 2023 B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,14 +26,20 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# revision date 2012/07/23
+# 20230418 bkw: BUILD=2
+# - new maintainer.
+# - move icon to /usr/share/icons (and symlink to pixmaps).
+# - make .desktop file validate with no warnings.
+# - replace README and slack-desc with something more descriptive.
+# - make unrar optional.
+# - document unrar and other decompressors in README.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=qcomicbook
SRCNAM=QComicBook
VERSION=${VERSION:-0.9.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -55,16 +62,12 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -e
@@ -76,39 +79,48 @@ rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# Icon info in the desktop file should not have a file extension
-sed -i 's/\.png$//' data/qcomicbook.desktop
+# 20230418 bkw: install man pages and icon in right places.
+sed -i 's,share/man,man,' help/CMakeLists.txt
+sed -i 's,pixmaps,icons/hicolor/48x48/apps,' data/CMakeLists.txt
-# Remove the iCCP chunk from the PNG images to avoid warnings
+# Icon info in the desktop file should not have a file extension.
+# 20230418 bkw: also, remove deprecated stuff.
+sed -i -e 's/\.png$//' \
+ -e 's,Application;,,' \
+ -e '/^Encoding/d' \
+ data/qcomicbook.desktop
+
+# Remove the iCCP chunk from the PNG images to avoid warnings.
for i in data/*.png; do
mv $i $i.old.png
convert $i.old.png $i
rm $i.old.png
done
-cmake . \
- -DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS -DNDEBUG" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
+mkdir build
+cd build
+ cmake .. \
+ -DCMAKE_CXX_FLAGS_RELEASE="$SLKCFLAGS -DNDEBUG" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make VERBOSE=1
+ make install/strip DESTDIR=$PKG
+cd -
-make VERBOSE=1
-make install/strip DESTDIR=$PKG
+gzip $PKG/usr/man/man*/*
-# Move manpage to correct location and gzip them
-mv $PKG/usr/share/man $PKG/usr/man
-gzip -9 $PKG/usr/man/man1/$PRGNAM.1
+mkdir -p $PKG/usr/share/pixmaps
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS COPYING ChangeLog README THANKS TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# NEWS is a 0-byte placeholder, do not package.
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a AUTHORS COPYING ChangeLog README THANKS TODO $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/graphics/qcomicbook/qcomicbook.info b/graphics/qcomicbook/qcomicbook.info
index 5555ba25c5..c1dd8e12ce 100644
--- a/graphics/qcomicbook/qcomicbook.info
+++ b/graphics/qcomicbook/qcomicbook.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/stolowski/QComicBook/archive/0.9.1/QComicBook-0.9.1
MD5SUM="d8762ff0698652cd2c383dbaa30cc132"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="unrar"
-MAINTAINER="Niels Horn"
-EMAIL="niels.horn@gmail.com"
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"
diff --git a/graphics/qcomicbook/slack-desc b/graphics/qcomicbook/slack-desc
index 7f2386c538..8430e4cdaf 100644
--- a/graphics/qcomicbook/slack-desc
+++ b/graphics/qcomicbook/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-qcomicbook: qcomicbook (Comic Book Reader)
-qcomicbook:
-qcomicbook: QComicBook is a graphical application that allows sequential
-qcomicbook: display of archived (zip or rar) images, a well known
-qcomicbook: technique for distributing digital copies of comic books.
-qcomicbook:
-qcomicbook: Homepage: https://github.com/stolowski/QComicBook
+qcomicbook: qcomicbook (comic book reader)
qcomicbook:
+qcomicbook: QComicBook is a viewer for PDF files and comic book archives
+qcomicbook: containing jpeg/png/xpm/gif/bmp images, which aims at convenience
+qcomicbook: and simplicity. Features include: automatic unpacking of archive
+qcomicbook: files, full-screen mode, continuous scrolling mode, double-pages
+qcomicbook: viewing, manga mode, thumbnails view, page scaling, mouse or keyboard
+qcomicbook: navigation etc.
qcomicbook:
qcomicbook:
qcomicbook: