summaryrefslogtreecommitdiffstats
path: root/graphics/vulkan-sdk
diff options
context:
space:
mode:
author orbea <orbea@riseup.net>2020-12-28 15:38:21 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-01-02 10:48:36 +0700
commit6e5562b33c462b0b7c8674c82e8c0cd69ea90670 (patch)
treefe5995910ed106059bcf3901f068d9174ef40635 /graphics/vulkan-sdk
parent0fd6cac3253ab591b420eb04fe3fb47df4575f32 (diff)
downloadslackbuilds-6e5562b33c462b0b7c8674c82e8c0cd69ea90670.tar.gz
slackbuilds-6e5562b33c462b0b7c8674c82e8c0cd69ea90670.tar.xz
graphics/vulkan-sdk: Updated for version 1.2.162.0.
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/vulkan-sdk')
-rw-r--r--graphics/vulkan-sdk/vulkan-sdk.SlackBuild19
-rw-r--r--graphics/vulkan-sdk/vulkan-sdk.info18
-rw-r--r--graphics/vulkan-sdk/vulkan-validationlayers-cmake.patch19
-rw-r--r--graphics/vulkan-sdk/vulkan-validationlayers-support.patch13
-rw-r--r--graphics/vulkan-sdk/vulkantools-support.patch13
5 files changed, 15 insertions, 67 deletions
diff --git a/graphics/vulkan-sdk/vulkan-sdk.SlackBuild b/graphics/vulkan-sdk/vulkan-sdk.SlackBuild
index 5d5d742ae8..86909bc79f 100644
--- a/graphics/vulkan-sdk/vulkan-sdk.SlackBuild
+++ b/graphics/vulkan-sdk/vulkan-sdk.SlackBuild
@@ -25,8 +25,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=vulkan-sdk
-VERSION=${VERSION:-1.2.154.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.2.162.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -141,16 +141,11 @@ chdir Vulkan-ValidationLayers-sdk-$VERSION
# Require an older cmake version.
sed -i 's/3.10.2/3.5.2/' CMakeLists.txt
-# Disable hardcoded errors
-patch -p1 < $CWD/vulkan-validationlayers-cmake.patch
-
-# Install into the vulkan directory to avoid conflicts
-patch -p1 < $CWD/vulkan-validationlayers-support.patch
-
cmake_build \
-DCMAKE_INSTALL_DATADIR=share \
-DBUILD_LAYER_SUPPORT_FILES=ON \
-DBUILD_TESTS=OFF \
+ -DBUILD_WERROR=OFF \
-DBUILD_WSI_XCB_SUPPORT=ON \
-DBUILD_WSI_XLIB_SUPPORT=ON \
-DBUILD_WSI_WAYLAND_SUPPORT=OFF \
@@ -170,9 +165,6 @@ chdir VulkanTools-sdk-$VERSION
python3 ./amalgamate.py
)
-# Update the include path
-patch -p1 < $CWD/vulkantools-support.patch
-
# Require an older cmake version.
find . -type f -name CMakeLists.txt | xargs grep -l '3\.10\.2' |
xargs sed -i 's/3.10.2/3.5.2/'
@@ -193,13 +185,14 @@ cmake_build \
chdir gfxreconstruct-sdk-$VERSION
-# Disable hardcoded errors
-sed -i '/-Werror/d' CMakeLists.txt
+# Require an older cmake version.
+sed -i 's/3.10.2/3.5.2/' CMakeLists.txt
# cmake 3.5.2 does not have FILTER for the list command
sed -i '/generate_target_source_files(/d' cmake/CodeStyle.cmake
cmake_build \
+ -DBUILD_WERROR=OFF \
-DVULKAN_HEADER=/usr/include/vulkan
cd -- "$SRC"
diff --git a/graphics/vulkan-sdk/vulkan-sdk.info b/graphics/vulkan-sdk/vulkan-sdk.info
index a7892a7020..879c8f7d73 100644
--- a/graphics/vulkan-sdk/vulkan-sdk.info
+++ b/graphics/vulkan-sdk/vulkan-sdk.info
@@ -1,15 +1,15 @@
PRGNAM="vulkan-sdk"
-VERSION="1.2.154.0"
+VERSION="1.2.162.0"
HOMEPAGE="https://www.khronos.org/vulkan/"
-DOWNLOAD="https://github.com/KhronosGroup/Vulkan-Loader/archive/sdk-1.2.154.0/Vulkan-Loader-sdk-1.2.154.0.tar.gz \
- https://github.com/KhronosGroup/Vulkan-ValidationLayers/archive/sdk-1.2.154.0/Vulkan-ValidationLayers-sdk-1.2.154.0.tar.gz \
- https://github.com/LunarG/VulkanTools/archive/sdk-1.2.154.0/VulkanTools-sdk-1.2.154.0.tar.gz \
- https://github.com/LunarG/gfxreconstruct/archive/sdk-1.2.154.0/gfxreconstruct-sdk-1.2.154.0.tar.gz \
+DOWNLOAD="https://github.com/KhronosGroup/Vulkan-Loader/archive/sdk-1.2.162.0/Vulkan-Loader-sdk-1.2.162.0.tar.gz \
+ https://github.com/KhronosGroup/Vulkan-ValidationLayers/archive/sdk-1.2.162.0/Vulkan-ValidationLayers-sdk-1.2.162.0.tar.gz \
+ https://github.com/LunarG/VulkanTools/archive/sdk-1.2.162.0/VulkanTools-sdk-1.2.162.0.tar.gz \
+ https://github.com/LunarG/gfxreconstruct/archive/sdk-1.2.162.0/gfxreconstruct-sdk-1.2.162.0.tar.gz \
https://github.com/open-source-parsers/jsoncpp/archive/1.8.0/jsoncpp-1.8.0.tar.gz"
-MD5SUM="26e6ad81252d01f27322851c01ea4ed4 \
- 922b963cc146acee9246927f4b79255b \
- 535b87b896571ca8c60d41f60f2b029d \
- 49bf75622c8ef36a7805baea5566ec9c \
+MD5SUM="97de90f2b599979ea492a3ed92c025fb \
+ 5c0c6daedacd2d535bb0cd41dcbd2995 \
+ aa116fff3ef50d7c299bc168953eacec \
+ 7d48f5d115f8baad2ed800769545f21a \
6d6cbd82b5fe4a9cbae4ffef01f9e9fc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
diff --git a/graphics/vulkan-sdk/vulkan-validationlayers-cmake.patch b/graphics/vulkan-sdk/vulkan-validationlayers-cmake.patch
deleted file mode 100644
index 797b1435e1..0000000000
--- a/graphics/vulkan-sdk/vulkan-validationlayers-cmake.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f328d7c7..45895dd4 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -117,14 +117,6 @@ if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
- -fno-builtin-memcmp
- -fvisibility=hidden)
-
-- # Treat warnings as errors for versions of GCC and c++11-compliant Clang versions that are shipped on Ubuntu 18.04 or older.
-- if((CMAKE_COMPILER_IS_GNUCXX AND NOT (CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 7.3.0)) OR
-- (("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang") AND
-- (CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 6.0.0) AND
-- (CMAKE_CXX_COMPILER_VERSION VERSION_LESS_EQUAL 7.0.0)))
-- add_compile_options(-Werror)
-- endif()
--
- set(CMAKE_C_STANDARD 99)
- set(CMAKE_CXX_STANDARD 11)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-rtti")
diff --git a/graphics/vulkan-sdk/vulkan-validationlayers-support.patch b/graphics/vulkan-sdk/vulkan-validationlayers-support.patch
deleted file mode 100644
index 0544dcdfd9..0000000000
--- a/graphics/vulkan-sdk/vulkan-validationlayers-support.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/layers/CMakeLists.txt b/layers/CMakeLists.txt
-index d1134e8e..a9e46f2b 100644
---- a/layers/CMakeLists.txt
-+++ b/layers/CMakeLists.txt
-@@ -72,7 +72,7 @@ if(BUILD_LAYER_SUPPORT_FILES)
- generated/vk_object_types.h
- generated/vk_extension_helper.h
- generated/vk_typemap_helper.h)
-- install(FILES ${LAYER_UTIL_FILES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-+ install(FILES ${LAYER_UTIL_FILES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/vulkan)
- endif()
-
- set(TARGET_NAMES
diff --git a/graphics/vulkan-sdk/vulkantools-support.patch b/graphics/vulkan-sdk/vulkantools-support.patch
deleted file mode 100644
index 319aacbde1..0000000000
--- a/graphics/vulkan-sdk/vulkantools-support.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7b45791f3..9101a3aad 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -76,7 +76,7 @@ endif()
- message(STATUS "Using Vulkan-ValidationLayers install located at ${VULKAN_VALIDATIONLAYERS_INSTALL_DIR}")
-
- file(TO_CMAKE_PATH "${VULKAN_VALIDATIONLAYERS_INSTALL_DIR}" VULKAN_VALIDATIONLAYERS_INSTALL_DIR)
--set(Vulkan-ValidationLayers_INCLUDE_DIR "${VULKAN_VALIDATIONLAYERS_INSTALL_DIR}/include")
-+set(Vulkan-ValidationLayers_INCLUDE_DIR "${VULKAN_VALIDATIONLAYERS_INSTALL_DIR}/include/vulkan")
- set(Vulkan-ValidationLayers_LIBRARY_DIR "${VULKAN_VALIDATIONLAYERS_INSTALL_DIR}/lib")
- find_library(VkLayer_utils_LIBRARY VkLayer_utils HINTS ${Vulkan-ValidationLayers_LIBRARY_DIR})
-