summaryrefslogtreecommitdiffstats
path: root/graphics/wavelet-denoise
diff options
context:
space:
mode:
author Stefano Guidoni <s.guidoni@email.it>2014-03-06 08:21:27 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-03-06 08:22:12 +0700
commitd3aa673913652a52d055b71f6ee3d76ca3e11f38 (patch)
treeb9c29682e1e656b32b05cd843e61bb4705209fae /graphics/wavelet-denoise
parentdd7eb1d21c8a1919e2b2d7c3f04374ec59ca7f45 (diff)
downloadslackbuilds-d3aa673913652a52d055b71f6ee3d76ca3e11f38.tar.gz
slackbuilds-d3aa673913652a52d055b71f6ee3d76ca3e11f38.tar.xz
graphics/wavelet-denoise: Added (GIMP plugin).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/wavelet-denoise')
-rw-r--r--graphics/wavelet-denoise/README5
-rw-r--r--graphics/wavelet-denoise/slack-desc19
-rw-r--r--graphics/wavelet-denoise/wavelet-denoise.SlackBuild81
-rw-r--r--graphics/wavelet-denoise/wavelet-denoise.info10
4 files changed, 115 insertions, 0 deletions
diff --git a/graphics/wavelet-denoise/README b/graphics/wavelet-denoise/README
new file mode 100644
index 0000000000..b96a2f61f9
--- /dev/null
+++ b/graphics/wavelet-denoise/README
@@ -0,0 +1,5 @@
+The wavelet denoise plugin for The GIMP reduces noise in an image using the
+algorithm copied and altered from the UFRaw program. Instead of denoising all
+RGB channels at once, the plugin implementation allows to denoise the RGB
+channels in dividually and - even more useful - to denoise the YCbCr or CIELAB
+channels individually.
diff --git a/graphics/wavelet-denoise/slack-desc b/graphics/wavelet-denoise/slack-desc
new file mode 100644
index 0000000000..daf2c6b1a6
--- /dev/null
+++ b/graphics/wavelet-denoise/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+wavelet-denoise: wavelet-denoise (GIMP plugin)
+wavelet-denoise:
+wavelet-denoise: the wavelet denoise plugin is a tool to reduce noise in each channel
+wavelet-denoise: of an image separately.
+wavelet-denoise:
+wavelet-denoise: The default colour space to do denoising is YCbCr which has the
+wavelet-denoise: advantage that chroma noise can be reduced without affecting image
+wavelet-denoise: details. Denoising in CIELAB or RGB is available as an option.
+wavelet-denoise:
+wavelet-denoise: http://registry.gimp.org/node/4235
+wavelet-denoise:
diff --git a/graphics/wavelet-denoise/wavelet-denoise.SlackBuild b/graphics/wavelet-denoise/wavelet-denoise.SlackBuild
new file mode 100644
index 0000000000..c0f7bac7f7
--- /dev/null
+++ b/graphics/wavelet-denoise/wavelet-denoise.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/sh
+
+# Slackware build script for wavelet-denoise
+# Originally written by klaatu for separate+
+# Adapted to wavelet-denoise by Stefano Guidoni
+
+PRGNAM=wavelet-denoise
+VERSION=${VERSION:-0.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ x86_64) ARCH=x86_64 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# it won't compile otherwise
+sed -e 's#$(LIBS)#$(LIBS) $(LDFLAGS)#' < src/Makefile > /tmp/Makefile && mv /tmp/Makefile src/Makefile
+
+LDFLAGS="-lm" \
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make all
+make install DESTDIR=$PKG
+
+mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/gimp/2.0/plug-ins
+cp -a src/wavelet-denoise $PKG/usr/lib$LIBDIRSUFFIX/gimp/2.0/plug-ins
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS README ChangeLog INSTALL COPYING THANKS TRANSLATIONS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/wavelet-denoise/wavelet-denoise.info b/graphics/wavelet-denoise/wavelet-denoise.info
new file mode 100644
index 0000000000..54d6d57b5d
--- /dev/null
+++ b/graphics/wavelet-denoise/wavelet-denoise.info
@@ -0,0 +1,10 @@
+PRGNAM="wavelet-denoise"
+VERSION="0.3.1"
+HOMEPAGE="http://registry.gimp.org/node/4235"
+DOWNLOAD="http://registry.gimp.org/files/wavelet-denoise-0.3.1.tar.gz"
+MD5SUM="a02862026857575cdf81b24477e42f4b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Stefano Guidoni"
+EMAIL="s.guidoni@email.it"