summaryrefslogtreecommitdiffstats
path: root/graphics/xdot
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2010-05-12 23:29:46 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:29:46 +0200
commitf1ff3efef1fdc18608a58f3f478da49596952d03 (patch)
treed43722740fcd57374747c9df8872359ff87e06f9 /graphics/xdot
parent7c81bab02dc24ab1b5194b2507b36fc063b181bb (diff)
downloadslackbuilds-f1ff3efef1fdc18608a58f3f478da49596952d03.tar.gz
slackbuilds-f1ff3efef1fdc18608a58f3f478da49596952d03.tar.xz
graphics/xdot: Added to 12.2 repository
Diffstat (limited to 'graphics/xdot')
-rw-r--r--graphics/xdot/README18
-rw-r--r--graphics/xdot/slack-desc19
-rw-r--r--graphics/xdot/xdot.SlackBuild72
-rw-r--r--graphics/xdot/xdot.info8
4 files changed, 117 insertions, 0 deletions
diff --git a/graphics/xdot/README b/graphics/xdot/README
new file mode 100644
index 0000000000..96f7b6f68e
--- /dev/null
+++ b/graphics/xdot/README
@@ -0,0 +1,18 @@
+xdot.py is an interactive viewer for graphs written in Graphviz's dot
+language.
+
+It uses internally the graphviz's xdot output format as an intermediate
+format, and PyGTK and Cairo for rendering.
+
+xdot.py can be used either as a standalone application from command line, or
+as a library embedded in your python application.
+
+Features:
+ * Since it doesn't use bitmaps it is fast and has a small memory footprint.
+ * Arbitrary zoom.
+ * Keyboard/mouse navigation.
+ * Supports events on the nodes with URLs.
+ * Animated jumping between nodes.
+ * Highlights node/edge under mouse.
+
+This package requires Graphviz and PyGTK, both avalaible at SlackBuilds.org.
diff --git a/graphics/xdot/slack-desc b/graphics/xdot/slack-desc
new file mode 100644
index 0000000000..3eac1fff10
--- /dev/null
+++ b/graphics/xdot/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+xdot: xdot (viewer for graphs written in Graphviz's dot language)
+xdot:
+xdot: xdot.py is an interactive viewer for graphs written in Graphviz's dot
+xdot: language.
+xdot: It uses internally the graphviz's xdot output format as an
+xdot: intermediate format, and PyGTK and Cairo for rendering.
+xdot: xdot.py can be used either as a standalone application from command
+xdot: line, or as a library embedded in your python application.
+xdot:
+xdot:
+xdot:
diff --git a/graphics/xdot/xdot.SlackBuild b/graphics/xdot/xdot.SlackBuild
new file mode 100644
index 0000000000..53a0b98131
--- /dev/null
+++ b/graphics/xdot/xdot.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for xdot.
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=xdot
+VERSION=20090403
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="LICENSE"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py bdist
+tar -xvf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/graphics/xdot/xdot.info b/graphics/xdot/xdot.info
new file mode 100644
index 0000000000..19cdb35cfc
--- /dev/null
+++ b/graphics/xdot/xdot.info
@@ -0,0 +1,8 @@
+PRGNAM="xdot"
+VERSION="20090403"
+HOMEPAGE="http://code.google.com/p/jrfonseca/wiki/XDot"
+DOWNLOAD="http://slackbuilds.org/sources/12.2/xdot-20090403.tar.bz2"
+MD5SUM="10cd274d114d4192a799f27336fb3410"
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"