summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2013-11-25 12:23:31 +0100
committer Heinz Wiesinger <pprkut@slackbuilds.org>2013-11-25 13:11:59 +0100
commit926b93d445e92be03e62efcd742b2ac88f0d96ed (patch)
treea9e1e616e37f2f7187d0b0ab2d8e83b3ad8eed63 /graphics
parent7bc7feac90a3966ebaea1b1ad87431764a560344 (diff)
downloadslackbuilds-926b93d445e92be03e62efcd742b2ac88f0d96ed.tar.gz
slackbuilds-926b93d445e92be03e62efcd742b2ac88f0d96ed.tar.xz
various: Replace chmod command with find command from template.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/LDView/LDView.SlackBuild6
-rw-r--r--graphics/dia/dia.SlackBuild6
-rw-r--r--graphics/enblend-enfuse/enblend-enfuse.SlackBuild6
-rw-r--r--graphics/evolus-pencil/evolus-pencil.SlackBuild6
-rw-r--r--graphics/exif/exif.SlackBuild6
-rw-r--r--graphics/gbdfed/gbdfed.SlackBuild6
-rw-r--r--graphics/gimp-lqr-plugin/gimp-lqr-plugin.SlackBuild6
-rw-r--r--graphics/gpscorrelate/gpscorrelate.SlackBuild6
-rw-r--r--graphics/hugin/hugin.SlackBuild6
-rw-r--r--graphics/inkscape/inkscape.SlackBuild6
-rw-r--r--graphics/jpeg2ps/jpeg2ps.SlackBuild6
-rw-r--r--graphics/ldglite/ldglite.SlackBuild6
-rw-r--r--graphics/leocad/leocad.SlackBuild6
-rw-r--r--graphics/luminance-hdr/luminance-hdr.SlackBuild6
-rw-r--r--graphics/mftrace/mftrace.SlackBuild6
-rw-r--r--graphics/openclipart/openclipart.SlackBuild6
-rw-r--r--graphics/pngquant/pngquant.SlackBuild6
-rw-r--r--graphics/potrace/potrace.SlackBuild6
-rw-r--r--graphics/povray/povray.SlackBuild6
-rw-r--r--graphics/qcomicbook/qcomicbook.SlackBuild6
-rw-r--r--graphics/resynthesizer/resynthesizer.SlackBuild6
-rw-r--r--graphics/screencloud/screencloud.SlackBuild6
-rw-r--r--graphics/scrot/scrot.SlackBuild6
-rw-r--r--graphics/xpe/xpe.SlackBuild6
-rw-r--r--graphics/yesplz/yesplz.SlackBuild6
25 files changed, 125 insertions, 25 deletions
diff --git a/graphics/LDView/LDView.SlackBuild b/graphics/LDView/LDView.SlackBuild
index 1ae08727fa..e14fa44f4f 100644
--- a/graphics/LDView/LDView.SlackBuild
+++ b/graphics/LDView/LDView.SlackBuild
@@ -69,7 +69,11 @@ cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch for a bug in QT, solves problems on NVIDIA cards
patch -p1 < $CWD/opengl.patch
diff --git a/graphics/dia/dia.SlackBuild b/graphics/dia/dia.SlackBuild
index 43eeaeadce..1f2f16754c 100644
--- a/graphics/dia/dia.SlackBuild
+++ b/graphics/dia/dia.SlackBuild
@@ -46,7 +46,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix the location of the French manpages.
sed -i 's/$(datadir)\/man/@mandir@/' doc/fr/Makefile.in
diff --git a/graphics/enblend-enfuse/enblend-enfuse.SlackBuild b/graphics/enblend-enfuse/enblend-enfuse.SlackBuild
index 1393110e3d..897c4148ff 100644
--- a/graphics/enblend-enfuse/enblend-enfuse.SlackBuild
+++ b/graphics/enblend-enfuse/enblend-enfuse.SlackBuild
@@ -64,7 +64,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CXXFLAGS="$SLKCFLAGS" \
CFLAGS="$SLKCFLAGS" \
diff --git a/graphics/evolus-pencil/evolus-pencil.SlackBuild b/graphics/evolus-pencil/evolus-pencil.SlackBuild
index 865bd83e81..1cfda95108 100644
--- a/graphics/evolus-pencil/evolus-pencil.SlackBuild
+++ b/graphics/evolus-pencil/evolus-pencil.SlackBuild
@@ -41,7 +41,11 @@ mkdir -p $TMP $PKG $OUTPUT
cd $PKG
rpm2cpio < $CWD/$PRGNAM-$VERSION-$APPBUILD.noarch.rpm | cpio -imdv
chown -R root:root .
-chmod -R u+w,go+r-w,a+X-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Increase MaxVersion requirement to work with newer xulrunner.
# Don't worry, it works.
diff --git a/graphics/exif/exif.SlackBuild b/graphics/exif/exif.SlackBuild
index 410cd4272f..191007568e 100644
--- a/graphics/exif/exif.SlackBuild
+++ b/graphics/exif/exif.SlackBuild
@@ -65,7 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/graphics/gbdfed/gbdfed.SlackBuild b/graphics/gbdfed/gbdfed.SlackBuild
index 8ab620133d..5e0480ce18 100644
--- a/graphics/gbdfed/gbdfed.SlackBuild
+++ b/graphics/gbdfed/gbdfed.SlackBuild
@@ -46,7 +46,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Remove the DEPRECATED flags for GTK+ > 2.20
sed -i 's/-DG_DISABLE_DEPRECATED/#-DG_DISABLE_DEPRECATED/' Makefile.in
diff --git a/graphics/gimp-lqr-plugin/gimp-lqr-plugin.SlackBuild b/graphics/gimp-lqr-plugin/gimp-lqr-plugin.SlackBuild
index 7829846bf4..ecfab9243a 100644
--- a/graphics/gimp-lqr-plugin/gimp-lqr-plugin.SlackBuild
+++ b/graphics/gimp-lqr-plugin/gimp-lqr-plugin.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/graphics/gpscorrelate/gpscorrelate.SlackBuild b/graphics/gpscorrelate/gpscorrelate.SlackBuild
index 6f7ef4e996..2dc37fcf81 100644
--- a/graphics/gpscorrelate/gpscorrelate.SlackBuild
+++ b/graphics/gpscorrelate/gpscorrelate.SlackBuild
@@ -65,7 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
make CFLAGS+="$SLKCFLAGS"
diff --git a/graphics/hugin/hugin.SlackBuild b/graphics/hugin/hugin.SlackBuild
index 6a686562e6..fb6d1439db 100644
--- a/graphics/hugin/hugin.SlackBuild
+++ b/graphics/hugin/hugin.SlackBuild
@@ -67,7 +67,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix pod encoding for Perl 5.18
# http://sourceforge.net/p/hugin/hugin/ci/aae44c4b0570e2cfc609e84d6e74d38a31453b73/
diff --git a/graphics/inkscape/inkscape.SlackBuild b/graphics/inkscape/inkscape.SlackBuild
index 7704f0e8e2..846070989c 100644
--- a/graphics/inkscape/inkscape.SlackBuild
+++ b/graphics/inkscape/inkscape.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/remove-stray-comma.diff
diff --git a/graphics/jpeg2ps/jpeg2ps.SlackBuild b/graphics/jpeg2ps/jpeg2ps.SlackBuild
index 9297022699..79901d9188 100644
--- a/graphics/jpeg2ps/jpeg2ps.SlackBuild
+++ b/graphics/jpeg2ps/jpeg2ps.SlackBuild
@@ -53,7 +53,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root.root .
-chmod -R a-s,u+rw,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
make -f Makefile "CC=gcc" "LD=gcc" "CFLAGS=-c $SLKCFLAGS"
mkdir -p $PKG/usr/bin
diff --git a/graphics/ldglite/ldglite.SlackBuild b/graphics/ldglite/ldglite.SlackBuild
index ad38b08607..bb49e120e2 100644
--- a/graphics/ldglite/ldglite.SlackBuild
+++ b/graphics/ldglite/ldglite.SlackBuild
@@ -68,7 +68,11 @@ cd $TMP
unzip $CWD/${PRGNAM}${SRCVERSION}src.zip -d $PRGNAM-$VERSION
cd $PRGNAM-$VERSION/$PRGNAM
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# patch makefile.linux to add SBO_FLAGS
patch < $CWD/cflags.patch
diff --git a/graphics/leocad/leocad.SlackBuild b/graphics/leocad/leocad.SlackBuild
index d6fde0be94..9172a8ab7e 100644
--- a/graphics/leocad/leocad.SlackBuild
+++ b/graphics/leocad/leocad.SlackBuild
@@ -65,7 +65,11 @@ cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION-src.tgz
cd $PRGNAM
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Include libs gcc-4.7 won't find by itself
sed "/^LIBS/s/=/= -lX11 -ldl/" -i Makefile
diff --git a/graphics/luminance-hdr/luminance-hdr.SlackBuild b/graphics/luminance-hdr/luminance-hdr.SlackBuild
index 6998806c08..2c83c8895d 100644
--- a/graphics/luminance-hdr/luminance-hdr.SlackBuild
+++ b/graphics/luminance-hdr/luminance-hdr.SlackBuild
@@ -62,7 +62,11 @@ rm -rf ${PRGNAM}-${VERSION}
tar xvf $CWD/${PRGNAM}-${VERSION}.tar.bz2
cd ${PRGNAM}-${VERSION}
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p build
cd build
diff --git a/graphics/mftrace/mftrace.SlackBuild b/graphics/mftrace/mftrace.SlackBuild
index 897b4c63b3..3ad875143e 100644
--- a/graphics/mftrace/mftrace.SlackBuild
+++ b/graphics/mftrace/mftrace.SlackBuild
@@ -65,7 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Make it support $SLKCFLAGS
sed -i "s/^CFLAGS =/CFLAGS +=/" GNUmakefile.in
diff --git a/graphics/openclipart/openclipart.SlackBuild b/graphics/openclipart/openclipart.SlackBuild
index deb573dc44..664f70e31c 100644
--- a/graphics/openclipart/openclipart.SlackBuild
+++ b/graphics/openclipart/openclipart.SlackBuild
@@ -47,7 +47,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p $PKG/usr/share/openclipart
mv * $PKG/usr/share/openclipart
diff --git a/graphics/pngquant/pngquant.SlackBuild b/graphics/pngquant/pngquant.SlackBuild
index 465c89640c..baa0a1d5a2 100644
--- a/graphics/pngquant/pngquant.SlackBuild
+++ b/graphics/pngquant/pngquant.SlackBuild
@@ -65,7 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION-src.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go-w,a+rX-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Remove unnecessary '-$(MAKEFLAGS)' in Makefiles.
sed -i 's/-\$(MAKEFLAGS)//g' Makefile lib/Makefile
diff --git a/graphics/potrace/potrace.SlackBuild b/graphics/potrace/potrace.SlackBuild
index 43fa1f35a0..9dcd4382cf 100644
--- a/graphics/potrace/potrace.SlackBuild
+++ b/graphics/potrace/potrace.SlackBuild
@@ -65,7 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go-w,a+rX-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# For metric units and papersizes, use the following flags to configure:
# --enable-metric Use metric units (centimeters) as default
diff --git a/graphics/povray/povray.SlackBuild b/graphics/povray/povray.SlackBuild
index f770277221..efef859fb3 100644
--- a/graphics/povray/povray.SlackBuild
+++ b/graphics/povray/povray.SlackBuild
@@ -75,7 +75,11 @@ else
fi
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
( cd unix; sh ./prebuild.sh )
diff --git a/graphics/qcomicbook/qcomicbook.SlackBuild b/graphics/qcomicbook/qcomicbook.SlackBuild
index 490e4db0d6..42ddc73533 100644
--- a/graphics/qcomicbook/qcomicbook.SlackBuild
+++ b/graphics/qcomicbook/qcomicbook.SlackBuild
@@ -67,7 +67,11 @@ cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cmake . \
-DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS -DNDEBUG" \
diff --git a/graphics/resynthesizer/resynthesizer.SlackBuild b/graphics/resynthesizer/resynthesizer.SlackBuild
index 9e9c7618b6..f3f6890fce 100644
--- a/graphics/resynthesizer/resynthesizer.SlackBuild
+++ b/graphics/resynthesizer/resynthesizer.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS"
diff --git a/graphics/screencloud/screencloud.SlackBuild b/graphics/screencloud/screencloud.SlackBuild
index 8847f61e31..dd0f8222fe 100644
--- a/graphics/screencloud/screencloud.SlackBuild
+++ b/graphics/screencloud/screencloud.SlackBuild
@@ -46,7 +46,11 @@ mkdir -p $TMP $PKG $OUTPUT
cd $PKG
ar p $CWD/screencloud_${VERSION}_${DEBARCH}.deb data.tar.gz | tar xvz
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
chmod 0755 $PKG
#rm -rf etc/
diff --git a/graphics/scrot/scrot.SlackBuild b/graphics/scrot/scrot.SlackBuild
index 01b96f92f3..c34c83b54c 100644
--- a/graphics/scrot/scrot.SlackBuild
+++ b/graphics/scrot/scrot.SlackBuild
@@ -45,7 +45,11 @@ rm -rf $PRGNAM-$VERSION
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/graphics/xpe/xpe.SlackBuild b/graphics/xpe/xpe.SlackBuild
index 573e866a22..7155e9ac1c 100644
--- a/graphics/xpe/xpe.SlackBuild
+++ b/graphics/xpe/xpe.SlackBuild
@@ -52,7 +52,11 @@ cd $TMP
tar xvf $CWD/${SRCPRGNAM}_${SRCVERSION}.tar.gz
cd ${SRCPRGNAM}
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CPPFLAGS="$SLKCFLAGS" \
diff --git a/graphics/yesplz/yesplz.SlackBuild b/graphics/yesplz/yesplz.SlackBuild
index 8ac6e41ebe..9ee9bdf0dd 100644
--- a/graphics/yesplz/yesplz.SlackBuild
+++ b/graphics/yesplz/yesplz.SlackBuild
@@ -48,7 +48,11 @@ rm -rf $PRGNAM\_$VERSION
tar xvf $CWD/$PRGNAM\_$VERSION.tgz
cd $PRGNAM\_$VERSION
chown -R root:root .
-chmod -R a-s,u+w,g-w+r,o-w+r .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
./configure \