summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Fernando Lopez Jr <fernando.lopezjr@gmail.com>2017-06-05 09:57:32 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-06-06 07:56:16 +0700
commitbc28c0d3e87f87cfde77301251fd2b0308c92068 (patch)
tree9df72e3ea0645a5ac6b290be4829066a3f4c2315 /graphics
parentd3cbd651332eed78c031eedde4c447be867e1e71 (diff)
downloadslackbuilds-bc28c0d3e87f87cfde77301251fd2b0308c92068.tar.gz
slackbuilds-bc28c0d3e87f87cfde77301251fd2b0308c92068.tar.xz
graphics/scour: Added (python SVG cleaner).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/scour/README3
-rw-r--r--graphics/scour/scour.SlackBuild86
-rw-r--r--graphics/scour/scour.info10
-rw-r--r--graphics/scour/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/graphics/scour/README b/graphics/scour/README
new file mode 100644
index 0000000000..182a86c6ff
--- /dev/null
+++ b/graphics/scour/README
@@ -0,0 +1,3 @@
+Scour is a Python tool that takes an SVG file and produces a cleaner
+and more concise file. It is intended to be used after exporting to SVG
+with a GUI editor, such as Inkscape or Adobe Illustrator.
diff --git a/graphics/scour/scour.SlackBuild b/graphics/scour/scour.SlackBuild
new file mode 100644
index 0000000000..88bbd54709
--- /dev/null
+++ b/graphics/scour/scour.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for scour
+
+# Written by Fernando Lopez Jr. <fernando.lopezjr[at]gmail[dot]com>
+# Copyright 2017 Fernando Lopez Jr.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=scour
+VERSION=${VERSION:-0.35}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md HISTORY.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/scour/scour.info b/graphics/scour/scour.info
new file mode 100644
index 0000000000..e5e3d49300
--- /dev/null
+++ b/graphics/scour/scour.info
@@ -0,0 +1,10 @@
+PRGNAM="scour"
+VERSION="0.35"
+HOMEPAGE="http://www.codedread.com/scour/"
+DOWNLOAD="https://github.com/scour-project/scour/archive/v0.35/scour-0.35.tar.gz"
+MD5SUM="811edeb8ec0991e491be38fbba13b76d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/graphics/scour/slack-desc b/graphics/scour/slack-desc
new file mode 100644
index 0000000000..ef3cf24596
--- /dev/null
+++ b/graphics/scour/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+scour: scour (python SVG cleaner)
+scour:
+scour: Scour is a Python tool that takes an SVG file and produces a
+scour: cleaner and more concise file. It is intended to be used after
+scour: exporting to SVG with a GUI editor, such as Inkscape or Adobe
+scour: Illustrator.
+scour:
+scour: Scour is open-source and licensed under Apache License 2.0.
+scour:
+scour:
+scour: