summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2015-04-11 14:28:05 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-04-11 14:28:05 +0700
commit448e1d0f2d1401a9dbee7cf0f52cdb4935ae3ae6 (patch)
tree87429ff18fdc9ab9d85df018ab07082abba9924b /graphics
parent036858edfe1cd695712f86fb3df524b0fa824578 (diff)
downloadslackbuilds-448e1d0f2d1401a9dbee7cf0f52cdb4935ae3ae6.tar.gz
slackbuilds-448e1d0f2d1401a9dbee7cf0f52cdb4935ae3ae6.tar.xz
graphics/uniconvertor: Added (universal vector graphics translator).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/uniconvertor/README2
-rw-r--r--graphics/uniconvertor/slack-desc19
-rw-r--r--graphics/uniconvertor/uniconvertor.SlackBuild84
-rw-r--r--graphics/uniconvertor/uniconvertor.info10
4 files changed, 115 insertions, 0 deletions
diff --git a/graphics/uniconvertor/README b/graphics/uniconvertor/README
new file mode 100644
index 0000000000..271786e000
--- /dev/null
+++ b/graphics/uniconvertor/README
@@ -0,0 +1,2 @@
+UniConvertor is a universal vector graphics translator.
+It uses sK1 engine to convert one format to another.
diff --git a/graphics/uniconvertor/slack-desc b/graphics/uniconvertor/slack-desc
new file mode 100644
index 0000000000..233f52e3de
--- /dev/null
+++ b/graphics/uniconvertor/slack-desc
@@ -0,0 +1,19 @@
+W TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+uniconvertor: uniconvertor (universal vector graphics translator)
+uniconvertor:
+uniconvertor:
+uniconvertor: UniConvertor is a universal vector graphics translator.
+uniconvertor: It uses sK1 engine to convert one format to another.
+uniconvertor:
+uniconvertor:
+uniconvertor:
+uniconvertor:
+uniconvertor: Homepage: http://sk1project.org
+uniconvertor:
diff --git a/graphics/uniconvertor/uniconvertor.SlackBuild b/graphics/uniconvertor/uniconvertor.SlackBuild
new file mode 100644
index 0000000000..874d792d85
--- /dev/null
+++ b/graphics/uniconvertor/uniconvertor.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for uniconvertor
+
+# Copyright 2015, Andre Barboza, Belo Horizonte, Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=uniconvertor
+VERSION=${VERSION:-1.1.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/uniconvertor/uniconvertor.info b/graphics/uniconvertor/uniconvertor.info
new file mode 100644
index 0000000000..5576dbc00d
--- /dev/null
+++ b/graphics/uniconvertor/uniconvertor.info
@@ -0,0 +1,10 @@
+PRGNAM="uniconvertor"
+VERSION="1.1.5"
+HOMEPAGE="http://sk1project.org"
+DOWNLOAD="http://uniconvertor.googlecode.com/files/uniconvertor-1.1.5.tar.gz"
+MD5SUM="d1272315a58304ece2ff588834e23f72"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="sk1libs"
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"