summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-24 21:27:28 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-29 06:58:15 +0700
commit56c1cf6848a75865409dfd983c4281098f13d959 (patch)
tree7c6714db5ab77baa3d5e7accf8798b8d8b35d4b5 /graphics
parent2b5829dd8d2fec61a05a24a1ba10076299a89542 (diff)
downloadslackbuilds-56c1cf6848a75865409dfd983c4281098f13d959.tar.gz
slackbuilds-56c1cf6848a75865409dfd983c4281098f13d959.tar.xz
graphics/Shellpic: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Shellpic/Shellpic.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/Shellpic/Shellpic.SlackBuild b/graphics/Shellpic/Shellpic.SlackBuild
index 3f2a3adb75..772c0c4dfe 100644
--- a/graphics/Shellpic/Shellpic.SlackBuild
+++ b/graphics/Shellpic/Shellpic.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Shellpic
-# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -30,7 +30,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -68,7 +68,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG