summaryrefslogtreecommitdiffstats
path: root/libraries/CAMD/autotoolize.diff
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2011-06-17 21:56:08 -0400
committer Robby Workman <rworkman@slackbuilds.org>2011-06-19 23:17:04 -0500
commitea19403bc3775faedc465959a9f29578b73af0a6 (patch)
tree1e0e14da59fd6466a592f283e01916282014f70c /libraries/CAMD/autotoolize.diff
parent84058ff57090bc444b5860727d4f4dbe7a673fb2 (diff)
downloadslackbuilds-ea19403bc3775faedc465959a9f29578b73af0a6.tar.gz
slackbuilds-ea19403bc3775faedc465959a9f29578b73af0a6.tar.xz
libraries/CAMD: Updated for version 2.2.2.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries/CAMD/autotoolize.diff')
-rw-r--r--libraries/CAMD/autotoolize.diff52
1 files changed, 42 insertions, 10 deletions
diff --git a/libraries/CAMD/autotoolize.diff b/libraries/CAMD/autotoolize.diff
index fe00b5d65a..4cbc5c76e2 100644
--- a/libraries/CAMD/autotoolize.diff
+++ b/libraries/CAMD/autotoolize.diff
@@ -3,7 +3,7 @@ new file mode 100644
--- /dev/null
+++ b/Demo/Makefile.am
@@ -0,0 +1,37 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
+LDADD = $(top_builddir)/Source/libcamd.la
+
+EXTRA_DIST = \
@@ -59,20 +59,29 @@ new file mode 100644
+
+clean-local:
+ -$(RM) *.aux *.bbl *.blg *.log *.toc
+diff --git a/Include/Makefile.am b/Include/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Include/Makefile.am
+@@ -0,0 +1,2 @@
++pkgincludedir = $(includedir)/camd
++pkginclude_HEADERS = camd.h camd_internal.h
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
-@@ -0,0 +1,3 @@
-+SUBDIRS = Source Demo Doc
+@@ -0,0 +1,5 @@
++SUBDIRS = Include Source Demo Doc
+EXTRA_DIST = README.txt
-+include_HEADERS = Include/camd.h Include/camd_internal.h
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = camd.pc
diff --git a/Source/Makefile.am b/Source/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Source/Makefile.am
@@ -0,0 +1,29 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
+
+CAMDSRC = \
+ camd_1.c \
@@ -100,14 +109,31 @@ new file mode 100644
+
+libcamd_la_SOURCES = camd_global.c
+libcamd_la_LIBADD = libcamdl.la libcamdi.la
-+libcamd_la_LDFLAGS = -no-undefined -version-info 4:1:2
++libcamd_la_LDFLAGS = -no-undefined -version-info 4:2:2
+diff --git a/camd.pc.in b/camd.pc.in
+new file mode 100644
+--- /dev/null
++++ b/camd.pc.in
+@@ -0,0 +1,12 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: Constrained approximate minimum degree ordering
++Version: @PACKAGE_VERSION@
++Requires.private: ufconfig
++Libs: -L${libdir} -lcamd
++Libs.private: -lm
++Cflags: -I${includedir}/camd
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
-@@ -0,0 +1,29 @@
-+AC_PREREQ([2.65])
-+AC_INIT([CAMD], [2.2.1], [davis@cise.ufl.edu])
+@@ -0,0 +1,35 @@
++AC_PREREQ([2.68])
++AC_INIT([CAMD],[2.2.2],[davis@cise.ufl.edu])
+AC_CONFIG_SRCDIR([Source/camd_global.c])
+AC_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE([foreign])
@@ -121,7 +147,11 @@ new file mode 100644
+AC_CHECK_LIB([m], [sqrt])
+
+AC_CHECK_HEADERS([limits.h stddef.h stdlib.h])
-+AC_CHECK_HEADERS([UFconfig.h])
++
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES([UFCONFIG],[ufconfig],
++ [],
++ [AC_MSG_ERROR([cannot find ufconfig])])
+
+AC_TYPE_SIZE_T
+
@@ -130,8 +160,10 @@ new file mode 100644
+LIBS=$LIBS_SAVED
+
+AC_CONFIG_FILES([
++ camd.pc
+ Makefile
+ Demo/Makefile
+ Doc/Makefile
++ Include/Makefile
+ Source/Makefile])
+AC_OUTPUT