summaryrefslogtreecommitdiffstats
path: root/libraries/alglib
diff options
context:
space:
mode:
author Petar Petrov <ppetrov@paju.oulu.fi>2011-12-11 08:59:30 -0200
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-11 08:59:30 -0200
commit81be65bc403d581ea31247e4c3e21e4c6a771d4d (patch)
treee93f8b4af6e8b63d8c6d19b4a359342bee8d4f9c /libraries/alglib
parentcf69bf514e4d1853f31cd9c82638b9ac8df58d0e (diff)
downloadslackbuilds-81be65bc403d581ea31247e4c3e21e4c6a771d4d.tar.gz
slackbuilds-81be65bc403d581ea31247e4c3e21e4c6a771d4d.tar.xz
libraries/alglib: Added (numerical analysis and data processing)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'libraries/alglib')
-rw-r--r--libraries/alglib/README17
-rw-r--r--libraries/alglib/alglib.SlackBuild101
-rw-r--r--libraries/alglib/alglib.info10
-rw-r--r--libraries/alglib/slack-desc19
4 files changed, 147 insertions, 0 deletions
diff --git a/libraries/alglib/README b/libraries/alglib/README
new file mode 100644
index 0000000000..986c19bba5
--- /dev/null
+++ b/libraries/alglib/README
@@ -0,0 +1,17 @@
+ALGLIB is a cross-platform numerical analysis and data processing
+library. ALGLIB features include:
+
+- Linear algebra (direct algorithms, EVD/SVD)
+- Solvers (linear and nonlinear)
+- Interpolation
+- Optimization
+- Fast Fourier transforms
+- Numerical integration
+- Linear and nonlinear least-squares fitting
+- Ordinary differential equations
+- Special functions
+- Statistics (descriptive statistics, hypothesis testing)
+- Data analysis (classification/regression, including neural networks)
+- Multiple precision versions of linear algebra, interpolation
+optimization and others algorithms (using MPFR for floating point
+computations)
diff --git a/libraries/alglib/alglib.SlackBuild b/libraries/alglib/alglib.SlackBuild
new file mode 100644
index 0000000000..b20d528438
--- /dev/null
+++ b/libraries/alglib/alglib.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# Slackware build script for alglib
+# Written by Petar Petrov, <ppetrov@paju.oulu.fi> and
+# hereby submitted to the public domain
+
+# Based on the alglib PKGBUILD from Archlinux AUR:
+# http://aur.archlinux.org/packages/al/alglib/PKGBUILD
+# PKGBUILD contributor is Carlo Casta. Thank you!
+
+# THIS SLACKBUILD IS DISTRIBUTETD IN THE HOPE OF BEING
+# USEFUL BUT WITHOUT ANY WARRANTY. THE AUTHOR IS _NOT_
+# RESPONSIBLE FOR ANY DAMAGE OR DATA LOSS CAUSED BY IT.
+
+PRGNAM=alglib
+VERSION=${VERSION:-2.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+unzip $CWD/alglib-2.6.0.cpp.zip
+cd cpp
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# build static lib
+cd src
+gcc $SLKFLAGS -I. -c *.cpp
+ar rcs libalglib.a *.o
+
+# build shared lib
+rm -f *.o
+gcc $SLKFLAGS -I. -fPIC -c *.cpp
+gcc $SLKFLAGS -shared -Wl,-soname,libalglib.so.2 -o libalglib.so.$VERSION *.o
+
+# install library
+install -D -m644 libalglib.a $PKG/usr/lib${LIBDIRSUFFIX}/libalglib.a
+install -D -m644 libalglib.so.$VERSION $PKG/usr/lib${LIBDIRSUFFIX}/libalglib.so.$VERSION
+
+# install headers
+mkdir -p $PKG/usr/include/libalglib
+install -m644 *.h $PKG/usr/include/libalglib
+
+# make a few symlinks
+cd $PKG/usr/lib${LIBDIRSUFFIX}
+ln -s libalglib.so.$VERSION libalglib.so.2
+ln -s libalglib.so.$VERSION libalglib.so
+cd $TMP/$PRGNAM-$VERSION/cpp
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ example manual.cpp.html \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz} \ No newline at end of file
diff --git a/libraries/alglib/alglib.info b/libraries/alglib/alglib.info
new file mode 100644
index 0000000000..9f05709939
--- /dev/null
+++ b/libraries/alglib/alglib.info
@@ -0,0 +1,10 @@
+PRGNAM="alglib"
+VERSION="2.6.0"
+HOMEPAGE="http://www.alglib.net/"
+DOWNLOAD="http://www.alglib.net/translator/re/alglib-2.6.0.cpp.zip"
+MD5SUM="cec14e4d399f01a6f68eecc0b44ebe7d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Petar Petrov"
+EMAIL="ppetrov@paju.oulu.fi"
+APPROVED="Niels Horn"
diff --git a/libraries/alglib/slack-desc b/libraries/alglib/slack-desc
new file mode 100644
index 0000000000..db525346de
--- /dev/null
+++ b/libraries/alglib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+alglib: alglib (A library for numerical analysis and data processing)
+alglib:
+alglib: ALGLIB is a cross-platform numerical analysis and data processing
+alglib: library.
+alglib:
+alglib:
+alglib:
+alglib:
+alglib:
+alglib:
+alglib: \ No newline at end of file