summaryrefslogtreecommitdiffstats
path: root/libraries/assimp
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-06-19 15:49:14 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-06-19 23:51:58 +0700
commit4d6ab92f608daf0a93050c2d137571743873a04a (patch)
treefee6a5cf2fca50978f6db5d833cfbd9965cdb01a /libraries/assimp
parent7d05cc82210001766ae576eeb6664ad442f6776d (diff)
downloadslackbuilds-4d6ab92f608daf0a93050c2d137571743873a04a.tar.gz
slackbuilds-4d6ab92f608daf0a93050c2d137571743873a04a.tar.xz
libraries/assimp: Updated for version 3.2.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'libraries/assimp')
-rw-r--r--libraries/assimp/README2
-rw-r--r--libraries/assimp/assimp.SlackBuild14
-rw-r--r--libraries/assimp/assimp.info10
-rw-r--r--libraries/assimp/assimp_x64.patch19
-rw-r--r--libraries/assimp/slack-desc2
5 files changed, 14 insertions, 33 deletions
diff --git a/libraries/assimp/README b/libraries/assimp/README
index 7a52197197..cafa737d79 100644
--- a/libraries/assimp/README
+++ b/libraries/assimp/README
@@ -3,3 +3,5 @@ load various 3d file formats and convert them into a shared,
in-memory format. It supports more than 30 file formats (basically,
it is like DevIL for 3D models). It also supports exporting, but the
number of export formats is lower.
+
+Optional dependency: libminizip
diff --git a/libraries/assimp/assimp.SlackBuild b/libraries/assimp/assimp.SlackBuild
index 6a165aace5..3276426c57 100644
--- a/libraries/assimp/assimp.SlackBuild
+++ b/libraries/assimp/assimp.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for assimp
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=assimp
-VERSION=${VERSION:-3.1.1}
+VERSION=${VERSION:-3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -67,11 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-if [ "$ARCH" = "x86_64" ]; then
- patch -p1 < $CWD/assimp_x64.patch
-fi
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p build
cd build
@@ -79,6 +75,8 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DASSIMP_LIB_INSTALL_DIR=/usr/lib${LIBDIRSUFFIX} \
+ -DASSIMP_BUILD_TESTS=OFF \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
@@ -88,7 +86,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES CREDITS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES CREDITS INSTALL LICENSE README *.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/assimp/assimp.info b/libraries/assimp/assimp.info
index 81ff4bd45f..263af9c4fb 100644
--- a/libraries/assimp/assimp.info
+++ b/libraries/assimp/assimp.info
@@ -1,10 +1,10 @@
PRGNAM="assimp"
-VERSION="3.1.1"
-HOMEPAGE="http://assimp.sourceforge.net/index.html"
-DOWNLOAD="https://github.com/assimp/assimp/archive/v3.1.1.tar.gz"
-MD5SUM="ab9977edf95e9b2910d7cca286926e85"
+VERSION="3.2"
+HOMEPAGE="http://www.assimp.org/"
+DOWNLOAD="https://github.com/assimp/assimp/archive/v3.2.tar.gz"
+MD5SUM="bb0cfa1513c4e11cf7ba14ba66548072"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="libminizip"
+REQUIRES=""
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/assimp/assimp_x64.patch b/libraries/assimp/assimp_x64.patch
deleted file mode 100644
index b59400adc8..0000000000
--- a/libraries/assimp/assimp_x64.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- assimp-3.1.1/CMakeLists.original.txt 2014-06-16 02:16:35.080910490 +0300
-+++ assimp-3.1.1/CMakeLists.txt 2014-06-16 02:19:22.898812477 +0300
-@@ -64,13 +64,13 @@
- # source tree. During an out-of-source build, however, do not litter this
- # directory, since that is probably what the user wanted to avoid.
- IF ( CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR )
-- SET( CMAKE_LIBRARY_OUTPUT_DIRECTORY "${CMAKE_HOME_DIRECTORY}/lib" )
-- SET( CMAKE_ARCHIVE_OUTPUT_DIRECTORY "${CMAKE_HOME_DIRECTORY}/lib" )
-+ SET( CMAKE_LIBRARY_OUTPUT_DIRECTORY "${CMAKE_HOME_DIRECTORY}/lib64" )
-+ SET( CMAKE_ARCHIVE_OUTPUT_DIRECTORY "${CMAKE_HOME_DIRECTORY}/lib64" )
- SET( CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_HOME_DIRECTORY}/bin" )
- ENDIF ( CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR )
-
- # Cache these to allow the user to override them manually.
--SET( ASSIMP_LIB_INSTALL_DIR "lib" CACHE PATH
-+SET( ASSIMP_LIB_INSTALL_DIR "lib64" CACHE PATH
- "Path the built library files are installed to." )
- SET( ASSIMP_INCLUDE_INSTALL_DIR "include" CACHE PATH
- "Path the header files are installed to." )
diff --git a/libraries/assimp/slack-desc b/libraries/assimp/slack-desc
index a35a32cb91..c8456740b3 100644
--- a/libraries/assimp/slack-desc
+++ b/libraries/assimp/slack-desc
@@ -14,6 +14,6 @@ assimp: in-memory format. It supports more than 30 file formats (basically,
assimp: it is like DevIL for 3D models). It also supports exporting, but
assimp: the number of export formats is lower.
assimp:
-assimp: Homepage: http://assimp.sourceforge.net/index.html
+assimp: Homepage: http://www.assimp.org/
assimp:
assimp: