summaryrefslogtreecommitdiffstats
path: root/libraries/aubio
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2016-03-13 17:58:03 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-03-15 00:26:15 +0700
commitd64a8bf6e859e4686f95126805f232290f378f40 (patch)
tree63c0b8f79d0e808ae4fa90600dac7972c01c67fa /libraries/aubio
parent374ccc48b63fc830bf36b79ef683f998147bf438 (diff)
downloadslackbuilds-d64a8bf6e859e4686f95126805f232290f378f40.tar.gz
slackbuilds-d64a8bf6e859e4686f95126805f232290f378f40.tar.xz
libraries/aubio: Updated for version 0.4.2.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'libraries/aubio')
-rw-r--r--libraries/aubio/README5
-rw-r--r--libraries/aubio/aubio.SlackBuild41
-rw-r--r--libraries/aubio/aubio.info6
3 files changed, 33 insertions, 19 deletions
diff --git a/libraries/aubio/README b/libraries/aubio/README
index 3f071e2582..512e909f40 100644
--- a/libraries/aubio/README
+++ b/libraries/aubio/README
@@ -5,4 +5,7 @@ live audio. The name aubio comes from 'audio' with a typo:
several transcription errors are likely to be found in the
results too.
-jack-audio-connection-kit is an optional dependency.
+jack-audio-connection-kit and ffmpeg are optional dependencies.
+
+To build the python bindings, pass BINDINGS=yes to the script.
+This depends on numpy.
diff --git a/libraries/aubio/aubio.SlackBuild b/libraries/aubio/aubio.SlackBuild
index fda64ed90b..5b0941a2bb 100644
--- a/libraries/aubio/aubio.SlackBuild
+++ b/libraries/aubio/aubio.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for aubio
-# Copyright 2008-2011 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2008-2016 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=aubio
-VERSION=0.3.2
-BUILD=${BUILD:-3}
+VERSION=0.4.2
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -60,7 +60,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -69,29 +69,40 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-LDFLAGS="-lm" \
+# Fix detecting ffmpeg
+sed -i "s|'HAVE_' + i in ctx.env.define_key|'HAVE_' + i in ctx.env|" \
+ wscript
+
+# Fix the build system...
+sed -i "s|'\${PREFIX}' + '/share/doc/libaubio-doc'|'\${DOCDIR}'|" wscript
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-./configure \
+./waf configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
- --disable-static \
- --build=$ARCH-slackware-linux \
- --host=$ARCH-slackware-linux
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-fftw3f
-make
-make install-strip DESTDIR=$PKG
+./waf build
-mkdir -p $PKG/usr/man/man1
-cp -f doc/*.1 $PKG/usr/man/man1/
+./waf install \
+ --destdir=$PKG
+
+if ! [ "${BINDINGS:-no}" = "no" ]; then
+ cd python
+ python setup.py install --root=$PKG
+ cd ..
+fi
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO VERSION \
+cp -a AUTHORS ChangeLog COPYING README.md VERSION \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/aubio/aubio.info b/libraries/aubio/aubio.info
index 0333091573..e52dec580e 100644
--- a/libraries/aubio/aubio.info
+++ b/libraries/aubio/aubio.info
@@ -1,8 +1,8 @@
PRGNAM="aubio"
-VERSION="0.3.2"
+VERSION="0.4.2"
HOMEPAGE="http://aubio.org/"
-DOWNLOAD="http://aubio.org/pub/aubio-0.3.2.tar.gz"
-MD5SUM="ffc3e5e4880fec67064f043252263a44"
+DOWNLOAD="http://aubio.org/pub/aubio-0.4.2.tar.bz2"
+MD5SUM="c0f6d8355e92669722501c3a762ba548"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""