summaryrefslogtreecommitdiffstats
path: root/libraries/compiz-plugins-unsupported
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2016-07-30 06:42:50 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-30 06:42:50 +0700
commit7e4a0077cd132ae6f096dc303132c0ea3430e720 (patch)
treeda01679bcd13a5be3a833fe07c6a3802e33c8a53 /libraries/compiz-plugins-unsupported
parentb743f0d1253597daa3704d68135851dc8b96eaf1 (diff)
downloadslackbuilds-7e4a0077cd132ae6f096dc303132c0ea3430e720.tar.gz
slackbuilds-7e4a0077cd132ae6f096dc303132c0ea3430e720.tar.xz
libraries/compiz-plugins-unsupported: Removed (merged).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/compiz-plugins-unsupported')
-rw-r--r--libraries/compiz-plugins-unsupported/README18
-rw-r--r--libraries/compiz-plugins-unsupported/README.POST_INSTALL10
-rw-r--r--libraries/compiz-plugins-unsupported/compiz-plugins-unsupported.SlackBuild87
-rw-r--r--libraries/compiz-plugins-unsupported/compiz-plugins-unsupported.info10
-rw-r--r--libraries/compiz-plugins-unsupported/slack-desc19
5 files changed, 0 insertions, 144 deletions
diff --git a/libraries/compiz-plugins-unsupported/README b/libraries/compiz-plugins-unsupported/README
deleted file mode 100644
index 0b774af429..0000000000
--- a/libraries/compiz-plugins-unsupported/README
+++ /dev/null
@@ -1,18 +0,0 @@
-The plugins in the Plugins Unsupported package are freely available for users
-to try, but they are not supported. Most of them offer miscellaneous eye candy
-or special utilities, but they are either quick demonstrations with few
-features, or likely to have bugs.
-
-For correct installation, build in this order:
- 1. compiz-bcop
- 2. protobuf (optional but recommended)
- 3. libcompizconfig
- 4. compizconfig-python
- 5. compizconfig-backend-kconfig4 (optional)
- 6. ccsm
- 7. compiz-plugins-main
- 8. compiz-plugins-extra (optional)
- 9. compiz-plugins-unsupported (optional)
-10. emerald (optional)
-11. emerald-themes (optional)
-12. fusion-icon (optional)
diff --git a/libraries/compiz-plugins-unsupported/README.POST_INSTALL b/libraries/compiz-plugins-unsupported/README.POST_INSTALL
deleted file mode 100644
index 3c8f207a68..0000000000
--- a/libraries/compiz-plugins-unsupported/README.POST_INSTALL
+++ /dev/null
@@ -1,10 +0,0 @@
-After you've installed the compiz-fusion packages you need to enable
-a few key features before you launch compiz.
-Launch "ccsm" and enable the following options:
-
- * Window Decorations
- * Move Window
- * Rezise Window
-
-These options will allow you to manage your windows.
-After enabled, you can launch compiz and customize to your liking.
diff --git a/libraries/compiz-plugins-unsupported/compiz-plugins-unsupported.SlackBuild b/libraries/compiz-plugins-unsupported/compiz-plugins-unsupported.SlackBuild
deleted file mode 100644
index 337b8b5683..0000000000
--- a/libraries/compiz-plugins-unsupported/compiz-plugins-unsupported.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for compiz-plugins-unsupported
-
-# Written by M.Dinslage (daedra1980@gmail.com)
-
-PRGNAM=compiz-plugins-unsupported
-VERSION=${VERSION:-0.8.10}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- SLKLDFLAGS=""; LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- SLKLDFLAGS=""; LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- SLKLDFLAGS="-L/usr/lib64"; LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- SLKLDFLAGS=""; LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf plugins-unsupported
-tar xvf $CWD/plugins-unsupported.tar.gz
-cd plugins-unsupported
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-./autogen.sh
-
-# Fix hardcoded checks for pango and cairo
-if [ "$ARCH" = "x86_64" ]; then
- sed -i 's,/lib/pkgconfig,/lib64/pkgconfig,g' configure
-fi
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-LDFLAGS="$SLKLDFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --enable-static=no \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING INSTALL NEWS VERSION $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/compiz-plugins-unsupported/compiz-plugins-unsupported.info b/libraries/compiz-plugins-unsupported/compiz-plugins-unsupported.info
deleted file mode 100644
index b4a896e8b9..0000000000
--- a/libraries/compiz-plugins-unsupported/compiz-plugins-unsupported.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="compiz-plugins-unsupported"
-VERSION="0.8.10"
-HOMEPAGE="http://www.compiz.org"
-DOWNLOAD="http://www.northfield.ws/projects/compiz/releases/0.8.10/plugins-unsupported.tar.gz"
-MD5SUM="a7391dfbc4f83546e866d84e6457555e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="ccsm compiz-plugins-main"
-MAINTAINER="M.Dinslage"
-EMAIL="daedra1980@gmail.com"
diff --git a/libraries/compiz-plugins-unsupported/slack-desc b/libraries/compiz-plugins-unsupported/slack-desc
deleted file mode 100644
index 969c94d951..0000000000
--- a/libraries/compiz-plugins-unsupported/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-compiz-plugins-unsupported: compiz-plugins-unsupported (Unsupported plugins for Compiz Fusion)
-compiz-plugins-unsupported:
-compiz-plugins-unsupported: This is the unsupported plugin set. All of the components should
-compiz-plugins-unsupported: work, but aren't officially supported by the development team.
-compiz-plugins-unsupported:
-compiz-plugins-unsupported:
-compiz-plugins-unsupported:
-compiz-plugins-unsupported:
-compiz-plugins-unsupported:
-compiz-plugins-unsupported:
-compiz-plugins-unsupported: