summaryrefslogtreecommitdiffstats
path: root/libraries/cssutils
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-05-12 23:30:05 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:30:05 +0200
commit4fc75e8f9a9f2a81716505a4d4582b06f2f995d2 (patch)
treeeba77614600ac2137104d0e3cf31b1e63bc63d8a /libraries/cssutils
parentf75af3af66dff97c60dc5f6b9c3c7732070cfb92 (diff)
downloadslackbuilds-4fc75e8f9a9f2a81716505a4d4582b06f2f995d2.tar.gz
slackbuilds-4fc75e8f9a9f2a81716505a4d4582b06f2f995d2.tar.xz
libraries/cssutils: Added to 12.2 repository
Diffstat (limited to 'libraries/cssutils')
-rw-r--r--libraries/cssutils/README3
-rw-r--r--libraries/cssutils/cssutils.SlackBuild57
-rw-r--r--libraries/cssutils/cssutils.info8
-rw-r--r--libraries/cssutils/slack-desc20
4 files changed, 88 insertions, 0 deletions
diff --git a/libraries/cssutils/README b/libraries/cssutils/README
new file mode 100644
index 0000000000..5c6cc697cf
--- /dev/null
+++ b/libraries/cssutils/README
@@ -0,0 +1,3 @@
+A Python package to parse and build CSS Cascading Style Sheets.
+
+Requires pysetuptools. \ No newline at end of file
diff --git a/libraries/cssutils/cssutils.SlackBuild b/libraries/cssutils/cssutils.SlackBuild
new file mode 100644
index 0000000000..473d73d4e7
--- /dev/null
+++ b/libraries/cssutils/cssutils.SlackBuild
@@ -0,0 +1,57 @@
+#!/bin/sh
+# Slackware build script for cssutils
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=cssutils
+VERSION=${VERSION:-0.9.6a4}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Change files from DOS to unix.
+for FILE in $(find . -type f -exec grep -Pl '\r\n' {} \;); do
+ tr -d '\r' < $FILE > ${FILE}.tmp
+ cat ${FILE}.tmp > $FILE
+ rm -f ${FILE}.tmp
+done
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ *.txt COPYING* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/cssutils/cssutils.info b/libraries/cssutils/cssutils.info
new file mode 100644
index 0000000000..144a502bcf
--- /dev/null
+++ b/libraries/cssutils/cssutils.info
@@ -0,0 +1,8 @@
+PRGNAM="cssutils"
+VERSION="0.9.6a4"
+HOMEPAGE="http://code.google.com/p/cssutils/"
+DOWNLOAD="http://cssutils.googlecode.com/files/cssutils-0.9.6a4.zip"
+MD5SUM="62c077d73853d318fd249bd3397fc5d6"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/libraries/cssutils/slack-desc b/libraries/cssutils/slack-desc
new file mode 100644
index 0000000000..b0661a808c
--- /dev/null
+++ b/libraries/cssutils/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+cssutils: cssutils (Package to parse and build CSS Cascading Style Sheets)
+cssutils:
+cssutils: A Python package to parse and build CSS Cascading Style Sheets.
+cssutils:
+cssutils: Homepage: http://code.google.com/p/cssutils/
+cssutils:
+cssutils:
+cssutils:
+cssutils:
+cssutils:
+cssutils:
+