summaryrefslogtreecommitdiffstats
path: root/libraries/decorator
diff options
context:
space:
mode:
author Mikko Varri <vmj@linuxbox.fi>2010-05-11 22:53:58 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 22:53:58 +0200
commited6d73b04b0ca21f081bc9dd909ff7889e12f2bf (patch)
treee18f8092dde8017a8f5eac87ec3a4460a9d8f9d2 /libraries/decorator
parent3ec5dbbd94e5f033eac26db55de546a81715127a (diff)
downloadslackbuilds-ed6d73b04b0ca21f081bc9dd909ff7889e12f2bf.tar.gz
slackbuilds-ed6d73b04b0ca21f081bc9dd909ff7889e12f2bf.tar.xz
libraries/decorator: Added to 12.1 repository
Diffstat (limited to 'libraries/decorator')
-rw-r--r--libraries/decorator/README9
-rw-r--r--libraries/decorator/decorator.SlackBuild45
-rw-r--r--libraries/decorator/decorator.info8
-rw-r--r--libraries/decorator/slack-desc19
4 files changed, 81 insertions, 0 deletions
diff --git a/libraries/decorator/README b/libraries/decorator/README
new file mode 100644
index 0000000000..c71dd12dc0
--- /dev/null
+++ b/libraries/decorator/README
@@ -0,0 +1,9 @@
+decorator (The decorator Python module)
+
+The aim of the decorator module it to simplify the usage of decorators
+for the average programmer, and to popularize decorators usage giving
+examples of useful decorators, such as memoize, tracing,
+redirecting_stdout, locked, etc.
+
+NOTE: Building this packages requires setuptools to be installed (available
+at SlackBuilds.org as pysetuptools).
diff --git a/libraries/decorator/decorator.SlackBuild b/libraries/decorator/decorator.SlackBuild
new file mode 100644
index 0000000000..d88648b5be
--- /dev/null
+++ b/libraries/decorator/decorator.SlackBuild
@@ -0,0 +1,45 @@
+#!/bin/sh
+
+# Slackware build script for decorator
+
+# Written by Mikko Varri (vmj@linuxbox.fi)
+# Public domain
+
+PRGNAM=decorator
+VERSION=${VERSION:-2.3.1}
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt README.txt documentation.* $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/decorator/decorator.info b/libraries/decorator/decorator.info
new file mode 100644
index 0000000000..2ecb546a0f
--- /dev/null
+++ b/libraries/decorator/decorator.info
@@ -0,0 +1,8 @@
+PRGNAM="decorator"
+VERSION="2.3.1"
+HOMEPAGE="http://www.phyast.pitt.edu/~micheles/python/documentation.html"
+DOWNLOAD="http://www.phyast.pitt.edu/~micheles/python/decorator-2.3.1.zip"
+MD5SUM="40c2d7a566a5f5264ef8d2a88d9261e9"
+MAINTAINER="Mikko Varri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="rworkman"
diff --git a/libraries/decorator/slack-desc b/libraries/decorator/slack-desc
new file mode 100644
index 0000000000..18a3e69586
--- /dev/null
+++ b/libraries/decorator/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+decorator: decorator (The decorator Python module)
+decorator:
+decorator: The aim of the decorator module it to simplify the usage of
+decorator: decorators for the average programmer, and to popularize decorators
+decorator: usage giving examples of useful decorators, such as memoize, tracing,
+decorator: redirecting_stdout, locked, etcetera.
+decorator:
+decorator: http://www.phyast.pitt.edu/~micheles/python/documentation.html
+decorator:
+decorator:
+decorator: