summaryrefslogtreecommitdiffstats
path: root/libraries/fltk2
diff options
context:
space:
mode:
author David Spencer <idlemoor@slackbuilds.org>2016-01-15 23:41:51 +0000
committer Robby Workman <rworkman@slackbuilds.org>2016-01-16 23:36:53 -0600
commitbc085eea84a0b3f114d01cd8f817adfce9ba2490 (patch)
treedfedcb5e8115f57594e6f4e07ef61f5d8add3244 /libraries/fltk2
parent2ae32ffea5a762c91e83e9a2da44e5f987e23e4a (diff)
downloadslackbuilds-bc085eea84a0b3f114d01cd8f817adfce9ba2490.tar.gz
slackbuilds-bc085eea84a0b3f114d01cd8f817adfce9ba2490.tar.xz
libraries/fltk2: Removed.
Nothing in the repo depends on this, it fails to build, and upstream describes it as a "previous experimental and now inactive branch". Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries/fltk2')
-rw-r--r--libraries/fltk2/README10
-rw-r--r--libraries/fltk2/fltk2.SlackBuild96
-rw-r--r--libraries/fltk2/fltk2.info10
-rw-r--r--libraries/fltk2/slack-desc19
4 files changed, 0 insertions, 135 deletions
diff --git a/libraries/fltk2/README b/libraries/fltk2/README
deleted file mode 100644
index 6d06b067ce..0000000000
--- a/libraries/fltk2/README
+++ /dev/null
@@ -1,10 +0,0 @@
-The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd C++
-graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
-Microsoft(r) Windows(r). It was originally developed by Mr. Bill Spitzak
-and is currently maintained by a small group of developers across the world
-with a central repository in the US.
-
-The build script is for the development branch (version 2.0.x), thus it is
-named "fltk2" to distinguish from the stable one ("fltk") available at
-SlackBuilds.org. Notice that fltk2 does not overwrite any files of fltk.
-Thus, it is possible to have both of them in the system if desired.
diff --git a/libraries/fltk2/fltk2.SlackBuild b/libraries/fltk2/fltk2.SlackBuild
deleted file mode 100644
index d4f9b5459c..0000000000
--- a/libraries/fltk2/fltk2.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for fltk, version 2
-#
-# Maintainer of the script: Mikhail Zotov <mikhail dot ru@gmail dot com>
-#
-# The script is based on the build script for FLTK, version 1, by LukenShiro.
-# The script has been fixed by the SlackBuilds.org team.
-
-PRGNAM=fltk2
-VERSION=${VERSION:-2.0.x_alpha_r9296}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRC_PRGNAM=fltk
-SRC_VERSION=$(printf $VERSION | tr _ -)
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCFILES="CHANGES COPYING CREDITS README README.unix README_fltk1_to_fltk2.txt"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRC_PRGNAM-$SRC_VERSION
-tar xvf $CWD/$SRC_PRGNAM-$SRC_VERSION.tar.bz2
-cd $SRC_PRGNAM-$SRC_VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix linking when --libdir=/usr/lib64
-sed -i \
- -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
- src/Makefile || exit
-
-# Make building more "verbose"
-sed -i 's/\.SILENT://' makeinclude.in
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man \
- --enable-shared \
- --build=$ARCH-slackware-linux
-
-make VERBOSE=1
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Remove empty directories since no manual pages are installed
-rm -rf $PKG/usr/man
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
-cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/fltk2/fltk2.info b/libraries/fltk2/fltk2.info
deleted file mode 100644
index 94bc711c33..0000000000
--- a/libraries/fltk2/fltk2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="fltk2"
-VERSION="2.0.x_alpha_r9296"
-HOMEPAGE="http://www.fltk.org/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/fltk-2.0.x-alpha-r9296.tar.bz2"
-MD5SUM="d4d62c0ec8f33881c05217d9b487da2d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Mikhail Zotov"
-EMAIL="mikhail dot ru at gmail dot com"
diff --git a/libraries/fltk2/slack-desc b/libraries/fltk2/slack-desc
deleted file mode 100644
index 916480d5c2..0000000000
--- a/libraries/fltk2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-fltk2: FLTK (Fast Light Tool Kit, version 2)
-fltk2:
-fltk2: The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
-fltk2: C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r),
-fltk2: and Microsoft(r) Windows(r). It was originally developed by Mr. Bill
-fltk2: Spitzak and is currently maintained by a small group of developers
-fltk2: across the world with a central repository in the US.
-fltk2:
-fltk2: Homepage: http://www.fltk.org/
-fltk2:
-fltk2: