summaryrefslogtreecommitdiffstats
path: root/libraries/gdata
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-05-13 00:58:30 +0200
committer Erik Hanson <erik@slackbuilds.org>2010-05-13 00:58:30 +0200
commitf825602ae6d1b69aa1bd88b5976085dec99a1554 (patch)
treecbdef4029c3e6a78a1903179940aa7da1bbf8f1d /libraries/gdata
parent8eda6777227681527405517d29fa698444648b13 (diff)
downloadslackbuilds-f825602ae6d1b69aa1bd88b5976085dec99a1554.tar.gz
slackbuilds-f825602ae6d1b69aa1bd88b5976085dec99a1554.tar.xz
libraries/gdata: Added to 13.0 repository
Diffstat (limited to 'libraries/gdata')
-rw-r--r--libraries/gdata/README18
-rw-r--r--libraries/gdata/deprecated_sha.patch21
-rw-r--r--libraries/gdata/gdata.SlackBuild55
-rw-r--r--libraries/gdata/gdata.info10
-rw-r--r--libraries/gdata/slack-desc19
5 files changed, 123 insertions, 0 deletions
diff --git a/libraries/gdata/README b/libraries/gdata/README
new file mode 100644
index 0000000000..3a34e40eb8
--- /dev/null
+++ b/libraries/gdata/README
@@ -0,0 +1,18 @@
+The GData (Google data) APIs provide a simple protocol for reading
+and writing data on the web. Each of the following Google services
+provides a Google data API:
+
+ * Base
+ * Blogger
+ * Calendar
+ * Code Search
+ * Contacts
+ * Document List
+ * Google Apps Provisioning
+ * Notebook
+ * Picasa Web Albums
+ * Spreadsheets
+ * YouTube
+
+The Google data Python client library provides a library and source
+code that make it easy to access data through Google data APIs.
diff --git a/libraries/gdata/deprecated_sha.patch b/libraries/gdata/deprecated_sha.patch
new file mode 100644
index 0000000000..7c52b337e1
--- /dev/null
+++ b/libraries/gdata/deprecated_sha.patch
@@ -0,0 +1,21 @@
+diff -Nur -x '*.orig' -x '*~' python-gdata-1.2.4/src/gdata/tlslite/utils/cryptomath.py python-gdata-1.2.4.new/src/gdata/tlslite/utils/cryptomath.py
+--- python-gdata-1.2.4/src/gdata/tlslite/utils/cryptomath.py 2008-12-02 03:35:26.000000000 +0100
++++ python-gdata-1.2.4.new/src/gdata/tlslite/utils/cryptomath.py 2009-05-19 00:44:00.000000000 +0200
+@@ -6,7 +6,7 @@
+ import math
+ import base64
+ import binascii
+-import sha
++import hashlib
+
+ from compat import *
+
+@@ -195,7 +195,7 @@
+ return int(math.ceil(bits / 8.0))
+
+ def hashAndBase64(s):
+- return stringToBase64(sha.sha(s).digest())
++ return stringToBase64(hashlib.sha1(s).digest())
+
+ def getBase64Nonce(numChars=22): #defaults to an 132 bit nonce
+ bytes = getRandomBytes(numChars)
diff --git a/libraries/gdata/gdata.SlackBuild b/libraries/gdata/gdata.SlackBuild
new file mode 100644
index 0000000000..4ce3615692
--- /dev/null
+++ b/libraries/gdata/gdata.SlackBuild
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+# Slackware build script for gdata
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=gdata
+VERSION=${VERSION:-2.0.6}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Replace deprecated sha variable with hashlib.
+patch -p1 < $CWD/deprecated_sha.patch
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ INSTALL.txt PKG-INFO README.txt RELEASE_NOTES.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/gdata/gdata.info b/libraries/gdata/gdata.info
new file mode 100644
index 0000000000..7fcd38a0ad
--- /dev/null
+++ b/libraries/gdata/gdata.info
@@ -0,0 +1,10 @@
+PRGNAM="gdata"
+VERSION="2.0.6"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/"
+DOWNLOAD="http://gdata-python-client.googlecode.com/files/gdata-2.0.6.tar.gz"
+MD5SUM="6f6a4ee9765889e4aab5e2a6ece5188e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="Erik Hanson"
diff --git a/libraries/gdata/slack-desc b/libraries/gdata/slack-desc
new file mode 100644
index 0000000000..354468bec3
--- /dev/null
+++ b/libraries/gdata/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+gdata: gdata (API to Google services)
+gdata:
+gdata: The Google Data APIs (Google Data) provide a simple protocol for
+gdata: reading and writing data on the web. Though it is possible to use
+gdata: these services with a simple HTTP client, this library provides
+gdata: helpful tools to streamline your code and keep up with server-side
+gdata: changes.
+gdata:
+gdata: Homepage: http://code.google.com/p/gdata-python-client/
+gdata:
+gdata: