summaryrefslogtreecommitdiffstats
path: root/libraries/geocode-glib
diff options
context:
space:
mode:
author Ozan Türkyılmaz <ozan.turkyilmaz@gmail.com>2022-04-02 10:11:41 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-02 18:19:22 +0700
commit9caff9fdd0ad563dd4a7ef39d8fbde9818837a6c (patch)
tree1247d003b68809da327acaa9edde9036c4267a80 /libraries/geocode-glib
parentab20a0b37e7cb358775743a743d34adfb915e8e1 (diff)
downloadslackbuilds-9caff9fdd0ad563dd4a7ef39d8fbde9818837a6c.tar.gz
slackbuilds-9caff9fdd0ad563dd4a7ef39d8fbde9818837a6c.tar.xz
libraries/geocode-glib: Added (library for geocoding)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/geocode-glib')
-rw-r--r--libraries/geocode-glib/README10
-rw-r--r--libraries/geocode-glib/doinst.sh6
-rw-r--r--libraries/geocode-glib/geocode-glib.SlackBuild122
-rw-r--r--libraries/geocode-glib/geocode-glib.info10
-rw-r--r--libraries/geocode-glib/patches/5604a210e7f1a0d3472d8a334e5cba4844fc177b.diff13
-rw-r--r--libraries/geocode-glib/slack-desc19
6 files changed, 180 insertions, 0 deletions
diff --git a/libraries/geocode-glib/README b/libraries/geocode-glib/README
new file mode 100644
index 0000000000..6a7e5196f1
--- /dev/null
+++ b/libraries/geocode-glib/README
@@ -0,0 +1,10 @@
+geocode-glib is a convenience library for the geocoding (finding
+longitude, and latitude from an address) and reverse geocoding
+(finding an address from coordinates). It uses Nominatim service to
+achieve that. It also caches (reverse-)geocoding requests for faster
+results and to avoid unnecessary server load.
+
+Below variables can be used to configure the build:
+ GTKDOC=true : Builds gtkdocs
+ INSTROSPECTION=true : Enables the introspection generation
+ TESTS=true : Build & install test programs
diff --git a/libraries/geocode-glib/doinst.sh b/libraries/geocode-glib/doinst.sh
new file mode 100644
index 0000000000..6c7c1b11b5
--- /dev/null
+++ b/libraries/geocode-glib/doinst.sh
@@ -0,0 +1,6 @@
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/libraries/geocode-glib/geocode-glib.SlackBuild b/libraries/geocode-glib/geocode-glib.SlackBuild
new file mode 100644
index 0000000000..2bb24c0427
--- /dev/null
+++ b/libraries/geocode-glib/geocode-glib.SlackBuild
@@ -0,0 +1,122 @@
+#!/bin/bash
+
+# Slackware build script for geocode-glib
+
+# Copyright 2022 Ozan Türkyılmaz
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=geocode-glib
+VERSION=${VERSION:-3.26.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+GTKDOC=${GTKDOC:-false}
+INSTROSPECTION=${INSTROSPECTION:-false}
+TESTS=${TESTS:-false}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Patch meson.build so icons goes under hicolor instead of gnome.
+patch -p1 < "$CWD"/patches/5604a210e7f1a0d3472d8a334e5cba4844fc177b.diff
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true \
+ -Denable-introspection="$INSTROSPECTION" \
+ -Denable-gtk-doc="$GTKDOC" \
+ -Denable-installed-tests="$TESTS"
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING.LIB ChangeLog NEWS README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/geocode-glib/geocode-glib.info b/libraries/geocode-glib/geocode-glib.info
new file mode 100644
index 0000000000..970e298b04
--- /dev/null
+++ b/libraries/geocode-glib/geocode-glib.info
@@ -0,0 +1,10 @@
+PRGNAM="geocode-glib"
+VERSION="3.26.2"
+HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
+DOWNLOAD="https://download.gnome.org/sources/geocode-glib/3.26/geocode-glib-3.26.2.tar.xz"
+MD5SUM="e1ef140a11a543643d170dc701009e39"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Ozan Türkyılmaz"
+EMAIL="ozan.turkyilmaz@gmail.com"
diff --git a/libraries/geocode-glib/patches/5604a210e7f1a0d3472d8a334e5cba4844fc177b.diff b/libraries/geocode-glib/patches/5604a210e7f1a0d3472d8a334e5cba4844fc177b.diff
new file mode 100644
index 0000000000..63758c8739
--- /dev/null
+++ b/libraries/geocode-glib/patches/5604a210e7f1a0d3472d8a334e5cba4844fc177b.diff
@@ -0,0 +1,13 @@
+diff --git a/icons/meson.build b/icons/meson.build
+index 370428a5f1d1035a336c83cad1d161281f1be61a..8d588865bdcf8f32fca12d2b918559e42b5e2d8e 100644
+--- a/icons/meson.build
++++ b/icons/meson.build
+@@ -15,7 +15,7 @@ foreach icon : public_icons
+ file = join_paths('maki' , icon)
+ install_dir = join_paths(get_option('datadir'),
+ 'icons',
+- 'gnome',
++ 'hicolor',
+ 'scalable',
+ 'places')
+
diff --git a/libraries/geocode-glib/slack-desc b/libraries/geocode-glib/slack-desc
new file mode 100644
index 0000000000..a71cb2d3b9
--- /dev/null
+++ b/libraries/geocode-glib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+geocode-glib: geocode-glib (convenience library for the geocoding)
+geocode-glib:
+geocode-glib: geocode-glib is a convenience library for the geocoding (finding
+geocode-glib: longitude, and latitude from an address) and reverse geocoding
+geocode-glib: (finding an address from coordinates). It uses Nominatim service to
+geocode-glib: achieve that. It also caches (reverse-)geocoding requests for faster
+geocode-glib: results and to avoid unnecessary server load.
+geocode-glib:
+geocode-glib: https://git.gnome.org/browse/geocode-glib
+geocode-glib:
+geocode-glib: