summaryrefslogtreecommitdiffstats
path: root/libraries/gtkhtml
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2021-08-29 10:21:11 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-08-30 06:55:50 +0700
commit22af4bd8682407b5aca5ce408b41653947b63179 (patch)
tree36e7b04524aa0099e9258e029a9897001606c0cf /libraries/gtkhtml
parentf266bd5d25d6a80014c4b2a554f0baee73f62584 (diff)
downloadslackbuilds-22af4bd8682407b5aca5ce408b41653947b63179.tar.gz
slackbuilds-22af4bd8682407b5aca5ce408b41653947b63179.tar.xz
libraries/gtkhtml: Patched for the newer enchant.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/gtkhtml')
-rw-r--r--libraries/gtkhtml/enchant-2.patch29
-rw-r--r--libraries/gtkhtml/gtkhtml.SlackBuild4
2 files changed, 33 insertions, 0 deletions
diff --git a/libraries/gtkhtml/enchant-2.patch b/libraries/gtkhtml/enchant-2.patch
new file mode 100644
index 0000000000..88a9d2c825
--- /dev/null
+++ b/libraries/gtkhtml/enchant-2.patch
@@ -0,0 +1,29 @@
+Description: Switch checks and functions for enchant-2
+ Existing sources check for and expect enchant-1. This patch switched the
+ pkg-config check to check for enchant-2, and updates one function to the
+ enchant-2 version.
+Author: Jonathon Fernyhough <jonathon at_manjaro_dot org>
+
+--- configure.ac 2018-02-24 10:33:32.311420000 +0000
++++ configure.ac 2018-02-24 10:32:33.630608000 +0000
+@@ -140,7 +140,7 @@ AC_SUBST(GAIL_MODULES)
+ dnl **********************************
+ dnl GTKHTML modules
+ dnl **********************************
+-GTKHTML_MODULES="gtk+-3.0 >= gtk_minimum_version enchant >= enchant_minimum_version gsettings-desktop-schemas iso-codes cairo >= cairo_minimum_version"
++GTKHTML_MODULES="gtk+-3.0 >= gtk_minimum_version enchant-2 >= enchant_minimum_version gsettings-desktop-schemas iso-codes cairo >= cairo_minimum_version"
+ PKG_CHECK_MODULES(GTKHTML, $GTKHTML_MODULES)
+ AC_SUBST(GTKHTML_CFLAGS)
+ AC_SUBST(GTKHTML_LIBS)
+
+--- components/editor/gtkhtml-spell-checker.c 2018-02-24 10:36:50.592732000 +0000
++++ components/editor/gtkhtml-spell-checker.c 2018-02-24 10:41:41.450950010 +0000
+@@ -375,7 +375,7 @@ gtkhtml_spell_checker_add_word (GtkhtmlS
+ if ((dict = spell_checker_request_dict (checker)) == NULL)
+ return;
+
+- enchant_dict_add_to_pwl (dict, word, length);
++ enchant_dict_add (dict, word, length);
+ g_signal_emit (G_OBJECT (checker), signals[ADDED], 0, word, length);
+ }
+
diff --git a/libraries/gtkhtml/gtkhtml.SlackBuild b/libraries/gtkhtml/gtkhtml.SlackBuild
index 6a656c2a80..81233c8733 100644
--- a/libraries/gtkhtml/gtkhtml.SlackBuild
+++ b/libraries/gtkhtml/gtkhtml.SlackBuild
@@ -79,6 +79,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p0 < $CWD/enchant-2.patch
+
+autoreconf -vif
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \