summaryrefslogtreecommitdiffstats
path: root/libraries/libbluray
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2012-04-02 15:03:34 -0400
committer Erik Hanson <erik@slackbuilds.org>2012-04-02 17:11:40 -0500
commit92fc67363d9e0ce591dcd71cc74bd53e3aef6182 (patch)
tree075593a229b4f184ce8e4af1b5131e54fd1082fc /libraries/libbluray
parent52a53e57d1503f6217ea9d002dff7ca9e58e84e4 (diff)
downloadslackbuilds-92fc67363d9e0ce591dcd71cc74bd53e3aef6182.tar.gz
slackbuilds-92fc67363d9e0ce591dcd71cc74bd53e3aef6182.tar.xz
libraries/libbluray: Updated for version 0.2.2.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries/libbluray')
-rw-r--r--libraries/libbluray/README5
-rw-r--r--libraries/libbluray/libbluray.SlackBuild15
-rw-r--r--libraries/libbluray/libbluray.info8
3 files changed, 20 insertions, 8 deletions
diff --git a/libraries/libbluray/README b/libraries/libbluray/README
index c6034fd5de..83e744c9c3 100644
--- a/libraries/libbluray/README
+++ b/libraries/libbluray/README
@@ -3,5 +3,10 @@ media players, like VLC or MPlayer. libbluray integrates navigation, playlist
parsing, menus and BD-J. libbluray is DRM-circumvention free, and thus, safe to
integrate in your software.
+libbluray has no dependencies. However, libbluray can make use of libaacs if
+it is installed. libbluray can also make use of java (aka bdjava) by
+additionally installing apache-ant and jdk and then running the script with
+the extra parameter BDJAVA=yes sh libbluray.SlackBuild.
+
Most commercial Blu-Ray are protected by AACS or BD+ technologies and this
library is not enough to playback those discs.
diff --git a/libraries/libbluray/libbluray.SlackBuild b/libraries/libbluray/libbluray.SlackBuild
index 64d94a2520..385037a7ba 100644
--- a/libraries/libbluray/libbluray.SlackBuild
+++ b/libraries/libbluray/libbluray.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=libbluray
-VERSION=${VERSION:-0.2.1}
+VERSION=${VERSION:-0.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -54,20 +54,27 @@ find . \
# Hack for compiling xine plugin bindings for libbluray.
sed -i -e '/pkg-config libbluray/d' -e 's|0644|0755|' player_wrappers/xine/Makefile
-# --enable-bdjava is turned off because specific files that are on vlc's
-# libbluray github site are not packaged in the source tarball.
+# If you want bdjava enabled then set BDAJVA=yes to the slackbuild.
+if [ "${BDJAVA:-no}" == 'yes' ]; then
+ OPT_ARGS="--enable-bdjava"
+else
+ OPT_ARGS="--disable-bdjava"
+fi
+
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--enable-debug=no \
--enable-static=no \
+ $OPT_ARGS \
--build=$ARCH-slackware-linux
CFLAGS="$SLKCFLAGS" make
make install DESTDIR=$PKG
CFLAGS="$SLKCFLAGS -I$PKG/usr/include" \
-LDFLAGS="-L$PKG/usr/lib$LIBDIRSUFFIX -lbluray" \
+LDFLAGS="-L$PKG/usr/lib$LIBDIRSUFFIX" \
+LIBS_BD="-lbluray" \
make -C player_wrappers/xine DESTDIR=$PKG install
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/libraries/libbluray/libbluray.info b/libraries/libbluray/libbluray.info
index b0e816aa21..8025bd38fd 100644
--- a/libraries/libbluray/libbluray.info
+++ b/libraries/libbluray/libbluray.info
@@ -1,10 +1,10 @@
PRGNAM="libbluray"
-VERSION="0.2.1"
+VERSION="0.2.2"
HOMEPAGE="http://www.videolan.org/developers/libbluray.html"
-DOWNLOAD="ftp://ftp.videolan.org/pub/videolan/libbluray/0.2.1/libbluray-0.2.1.tar.bz2"
-MD5SUM="d4cfcf3f110e9d2afe01d29feb8c842b"
+DOWNLOAD="ftp://ftp.videolan.org/pub/videolan/libbluray/0.2.2/libbluray-0.2.2.tar.bz2"
+MD5SUM="cb3254de43276861ea6b07c603f4651c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="rworkman"
+APPROVED="dsomero"