summaryrefslogtreecommitdiffstats
path: root/libraries/libflashsupport
diff options
context:
space:
mode:
author Mauro Giachero <mauro dot giachero at gmail dot com>2010-05-11 22:54:05 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-11 22:54:05 +0200
commit462de9b508542d5069211314532b588eb28be0d4 (patch)
tree9cfa20c733324acbc60bc9ce8108e438eba1ae91 /libraries/libflashsupport
parentfa9af533cb57d578eb60335c7cb95df7b2d4c466 (diff)
downloadslackbuilds-462de9b508542d5069211314532b588eb28be0d4.tar.gz
slackbuilds-462de9b508542d5069211314532b588eb28be0d4.tar.xz
libraries/libflashsupport: Added to 12.1 repository
Diffstat (limited to 'libraries/libflashsupport')
-rw-r--r--libraries/libflashsupport/README10
-rw-r--r--libraries/libflashsupport/change-features.patch17
-rw-r--r--libraries/libflashsupport/disable-pulse.patch32
-rw-r--r--libraries/libflashsupport/libflashsupport.SlackBuild97
-rw-r--r--libraries/libflashsupport/libflashsupport.info8
-rw-r--r--libraries/libflashsupport/slack-desc19
6 files changed, 183 insertions, 0 deletions
diff --git a/libraries/libflashsupport/README b/libraries/libflashsupport/README
new file mode 100644
index 0000000000..96c507c90b
--- /dev/null
+++ b/libraries/libflashsupport/README
@@ -0,0 +1,10 @@
+libflashsupport is an additional library for Adobe Flash Player adding
+support for TLS, OSS and optionally PulseAudio.
+This library is known to solve problems about missing audio from Flash
+content, like videos embedded into web pages.
+
+To build with PulseAudio support, start the script with PULSE=yes, as
+in:
+ PULSE=yes ./libflashsupport.SlackBuild
+This requires that you have already installed pulseaudio, available
+from SlackBuilds.org.
diff --git a/libraries/libflashsupport/change-features.patch b/libraries/libflashsupport/change-features.patch
new file mode 100644
index 0000000000..b99b0f132c
--- /dev/null
+++ b/libraries/libflashsupport/change-features.patch
@@ -0,0 +1,17 @@
+diff -urp libflashsupport-ORIGINALE/flashsupport.c libflashsupport-MODIFICATO/flashsupport.c
+--- libflashsupport-ORIGINALE/flashsupport.c 2008-07-02 11:43:50.000000000 +0200
++++ libflashsupport-MODIFICATO/flashsupport.c 2008-07-02 11:46:33.000000000 +0200
+@@ -50,10 +50,10 @@
+ //
+
+ #define OPENSSL
+-//#define GNUTLS
++#define GNUTLS
+ //#define ALSA
+-//#define OSS
+-#define V4L1
++#define OSS
++//#define V4L1
+ #define PULSEAUDIO
+
+ ////////////////////////////////////////////////////////////////////////////////////////////////////
diff --git a/libraries/libflashsupport/disable-pulse.patch b/libraries/libflashsupport/disable-pulse.patch
new file mode 100644
index 0000000000..f74dc225e8
--- /dev/null
+++ b/libraries/libflashsupport/disable-pulse.patch
@@ -0,0 +1,32 @@
+diff -urp libflashsupport-MODIFICATO/configure.ac libflashsupport-MODIFICATO-NOPULSE/configure.ac
+--- libflashsupport-MODIFICATO/configure.ac 2008-07-02 11:43:50.000000000 +0200
++++ libflashsupport-MODIFICATO-NOPULSE/configure.ac 2008-07-02 11:48:52.000000000 +0200
+@@ -79,12 +79,12 @@ elif test -d ../pulseaudio ; then
+ PULSE_CFLAGS='-I$(top_srcdir)/../pulseaudio/src'
+ PULSE_LIBS='-L$(top_srcdir)/../pulseaudio/src/.libs -lpulse'
+ echo "*** Found pulseaudio in ../pulseaudio, using that version ***"
+-else
+- PKG_CHECK_MODULES(PULSE, [ libpulse >= 0.9.5 ])
++#else
++# PKG_CHECK_MODULES(PULSE, [ libpulse >= 0.9.5 ])
+ fi
+
+-AC_SUBST(PULSE_LIBS)
+-AC_SUBST(PULSE_CFLAGS)
++#AC_SUBST(PULSE_LIBS)
++#AC_SUBST(PULSE_CFLAGS)
+
+ PKG_CHECK_MODULES(LIBSSL, [ libssl ])
+
+diff -urp libflashsupport-MODIFICATO/flashsupport.c libflashsupport-MODIFICATO-NOPULSE/flashsupport.c
+--- libflashsupport-MODIFICATO/flashsupport.c 2008-07-02 11:46:33.000000000 +0200
++++ libflashsupport-MODIFICATO-NOPULSE/flashsupport.c 2008-07-02 11:48:21.000000000 +0200
+@@ -54,7 +54,7 @@
+ //#define ALSA
+ #define OSS
+ //#define V4L1
+-#define PULSEAUDIO
++//#define PULSEAUDIO
+
+ ////////////////////////////////////////////////////////////////////////////////////////////////////
+ //
diff --git a/libraries/libflashsupport/libflashsupport.SlackBuild b/libraries/libflashsupport/libflashsupport.SlackBuild
new file mode 100644
index 0000000000..4fb7eb29e7
--- /dev/null
+++ b/libraries/libflashsupport/libflashsupport.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/sh
+
+# Slackware build script for libflashsupport
+
+# Written by Mauro Giachero (mauro dot giachero at gmail dot com)
+
+# Copyright 2008 Mauro Giachero
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libflashsupport
+VERSION=${VERSION:-20080328}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# If you want PulseAudio support, start with PULSE=yes
+PULSE=${PULSE:-no}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Enable OSS and GNUTLS support
+patch -p1 <$CWD/change-features.patch
+
+# Disable PulseAudio
+[ "$PULSE" = "no" ] && patch -p1 <$CWD/disable-pulse.patch
+
+NOCONFIGURE=yes \
+./bootstrap.sh
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+
+make
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+# The license is in the source file. Extract it.
+head -n $(grep -n -m1 "\*/" flashsupport.c |cut -d: -f1) flashsupport.c \
+ >$PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/libflashsupport/libflashsupport.info b/libraries/libflashsupport/libflashsupport.info
new file mode 100644
index 0000000000..abf2017b3b
--- /dev/null
+++ b/libraries/libflashsupport/libflashsupport.info
@@ -0,0 +1,8 @@
+PRGNAM="libflashsupport"
+VERSION="20080328"
+HOMEPAGE="http://www.pulseaudio.org/wiki/FlashPlayer9Solution"
+DOWNLOAD="http://gamma.unipv.it/mirror/libflashsupport-20080328.tar.gz"
+MD5SUM="1e6009d6ff98213e2932ebe6233db93f"
+MAINTAINER="Mauro Giachero"
+EMAIL="mauro dot giachero at gmail dot com"
+APPROVED="David Somero"
diff --git a/libraries/libflashsupport/slack-desc b/libraries/libflashsupport/slack-desc
new file mode 100644
index 0000000000..89a3ffe3cf
--- /dev/null
+++ b/libraries/libflashsupport/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+libflashsupport: libflashsupport (improve Adobe Flash Player platform support)
+libflashsupport:
+libflashsupport: libflashsupport is an experimental library adding support for TLS
+libflashsupport: and non-ALSA sound systems to Adobe Flash Player.
+libflashsupport:
+libflashsupport: Homepage: http://www.pulseaudio.org/wiki/FlashPlayer9Solution
+libflashsupport:
+libflashsupport:
+libflashsupport:
+libflashsupport:
+libflashsupport: