summaryrefslogtreecommitdiffstats
path: root/libraries/libgnomeprint
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2015-05-28 20:14:30 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-01-17 09:40:16 +0700
commit3d820728f46a0f4914c03a585ce0c1da885a9e4c (patch)
tree4de4d3d22d5bfba47f0d6bb3462db0298ae1a935 /libraries/libgnomeprint
parentbed8d857f8e44718904295cf7c491aab26fc6e7a (diff)
downloadslackbuilds-3d820728f46a0f4914c03a585ce0c1da885a9e4c.tar.gz
slackbuilds-3d820728f46a0f4914c03a585ce0c1da885a9e4c.tar.xz
libraries/libgnomeprint: Patched to fix build on -current.
Signed-off-by: David Spencer <baildon.research@googlemail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/libgnomeprint')
-rw-r--r--libraries/libgnomeprint/libgnomeprint-2.18.8-bison3.patch39
-rw-r--r--libraries/libgnomeprint/libgnomeprint-2.18.8-cups-config.patch39
-rw-r--r--libraries/libgnomeprint/libgnomeprint.SlackBuild4
3 files changed, 82 insertions, 0 deletions
diff --git a/libraries/libgnomeprint/libgnomeprint-2.18.8-bison3.patch b/libraries/libgnomeprint/libgnomeprint-2.18.8-bison3.patch
new file mode 100644
index 0000000000..d9fbbdd84f
--- /dev/null
+++ b/libraries/libgnomeprint/libgnomeprint-2.18.8-bison3.patch
@@ -0,0 +1,39 @@
+http://git.pld-linux.org/gitweb.cgi?p=packages/libgnomeprint.git;a=blob;f=bison3.patch
+
+--- libgnomeprint-2.18.8/libgnomeprint/grammar.y.orig 2010-02-09 13:32:51.000000000 +0100
++++ libgnomeprint-2.18.8/libgnomeprint/grammar.y 2013-11-03 21:44:59.859877696 +0100
+@@ -6,8 +6,6 @@
+ #include <libgnomeprint/types.h>
+ #include <libgnomeprint/gnome-print-filter.h>
+
+-#define YYPARSE_PARAM graph
+-
+ static void
+ set_value_from_string (GParamSpec *pspec, GValue *v, const gchar *s)
+ {
+@@ -99,7 +97,7 @@
+ }
+
+ static int yylex (void *lvalp);
+-static int yyerror (const char *s);
++static int yyerror (graph_t *g, const char *s);
+ %}
+
+ %union {
+@@ -117,6 +115,7 @@
+ %type <p> pool
+
+ %pure_parser
++%parse-param { graph_t *graph }
+
+ %start graph
+ %%
+@@ -185,7 +184,7 @@
+ %%
+
+ static int
+-yyerror (const char *s)
++yyerror (graph_t *g, const char *s)
+ {
+ return -1;
+ }
diff --git a/libraries/libgnomeprint/libgnomeprint-2.18.8-cups-config.patch b/libraries/libgnomeprint/libgnomeprint-2.18.8-cups-config.patch
new file mode 100644
index 0000000000..999c6f0752
--- /dev/null
+++ b/libraries/libgnomeprint/libgnomeprint-2.18.8-cups-config.patch
@@ -0,0 +1,39 @@
+From ffbc68cc8518c7e7263a42d4284b749b40c5e871 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 29 Jun 2014 10:47:41 +0200
+Subject: [PATCH] Use AC_PATH_TOOL to find proper cups-config.
+
+---
+ configure.in | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 729278d..186fabf 100644
+--- a/configure.in
++++ b/configure.in
+@@ -223,17 +223,18 @@ AC_ARG_WITH(cups,
+ )
+ if test "x$try_cups" = "xyes"; then
+ PKG_CHECK_MODULES(CUPS, "gmodule-2.0")
++ AC_PATH_TOOL(CUPS_CONFIG, cups-config)
+ AC_MSG_CHECKING(for CUPS libraries version >= 1.1.20)
+- if cups-config --version --libs > /dev/null 2>&1; then
+- verstxt=`cups-config --version`
++ if $CUPS_CONFIG --version --libs > /dev/null 2>&1; then
++ verstxt=`$CUPS_CONFIG --version`
+ vers=`echo "$verstxt" | \
+ awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+ if test "$vers" -lt 1001020; then
+ AC_MSG_RESULT(Cups found but the version found is less than 1.1.20)
+ cups_msg="Version requirement not satisfied"
+ else
+- CUPS_LIBS="$CUPS_LIBS `cups-config --ldflags` `cups-config --libs`"
+- CUPS_CFLAGS="$CUPS_CFLAGS `cups-config --cflags`"
++ CUPS_LIBS="$CUPS_LIBS `$CUPS_CONFIG --ldflags` `$CUPS_CONFIG --libs`"
++ CUPS_CFLAGS="$CUPS_CFLAGS `$CUPS_CONFIG --cflags`"
+ AC_MSG_RESULT(Found version $verstxt)
+ fi
+
+--
+2.0.0
+
diff --git a/libraries/libgnomeprint/libgnomeprint.SlackBuild b/libraries/libgnomeprint/libgnomeprint.SlackBuild
index e2e508ec56..9795ed648b 100644
--- a/libraries/libgnomeprint/libgnomeprint.SlackBuild
+++ b/libraries/libgnomeprint/libgnomeprint.SlackBuild
@@ -71,7 +71,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Thanks to Gentoo for these three patches
+# https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/gnome-base/libgnomeprint/files/
patch -p1 -i $CWD/libgnomeprint-2.18.8-stdio-include.patch
+patch -p1 -i $CWD/libgnomeprint-2.18.8-bison3.patch
+patch -p1 -i $CWD/libgnomeprint-2.18.8-cups-config.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \