summaryrefslogtreecommitdiffstats
path: root/libraries/libilbc
diff options
context:
space:
mode:
author David Woodfall <dave@dawoodfall.net>2013-11-02 23:05:36 +0100
committer Robby Workman <rworkman@slackbuilds.org>2013-11-02 23:24:07 -0500
commit244d775f32b5386793dae1510d67c12e0ac77650 (patch)
tree168604351aa84b5e324dedf7a81c19d19782e4b9 /libraries/libilbc
parente1c59ba9edd3df2d6a752ed5bcf3f5102373c70c (diff)
downloadslackbuilds-244d775f32b5386793dae1510d67c12e0ac77650.tar.gz
slackbuilds-244d775f32b5386793dae1510d67c12e0ac77650.tar.xz
libraries/libilbc: Added.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'libraries/libilbc')
-rw-r--r--libraries/libilbc/README3
-rw-r--r--libraries/libilbc/libilbc.SlackBuild100
-rw-r--r--libraries/libilbc/libilbc.info10
-rw-r--r--libraries/libilbc/slack-desc19
4 files changed, 132 insertions, 0 deletions
diff --git a/libraries/libilbc/README b/libraries/libilbc/README
new file mode 100644
index 0000000000..54de6d844d
--- /dev/null
+++ b/libraries/libilbc/README
@@ -0,0 +1,3 @@
+iLBC codec from the WebRTC project. It provides a base for distribution
+packages and can be used as drop-in replacement for the non-free code
+from RFC 3591.
diff --git a/libraries/libilbc/libilbc.SlackBuild b/libraries/libilbc/libilbc.SlackBuild
new file mode 100644
index 0000000000..dcb7f77dc7
--- /dev/null
+++ b/libraries/libilbc/libilbc.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/sh
+
+# Slackware build script for libilbc
+# Copyright 2013 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libilbc
+VERSION=${VERSION:-git20131002}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# fix libdir
+sed -i "s|lib/\${CMAKE_LIBRARY_ARCHITECTURE}|lib\${LIB_SUFFIX}|g" \
+ CMakeLists.txt
+
+mkdir build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING INSTALL README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libilbc/libilbc.info b/libraries/libilbc/libilbc.info
new file mode 100644
index 0000000000..f3c4837e70
--- /dev/null
+++ b/libraries/libilbc/libilbc.info
@@ -0,0 +1,10 @@
+PRGNAM="libilbc"
+VERSION="git20131002"
+HOMEPAGE="https://github.com/dekkers/libilbc"
+DOWNLOAD="http://www.unrealize.co.uk/source/libilbc-git20131002.tar.gz"
+MD5SUM="45b7a45f765815a9950a68743430d634"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
diff --git a/libraries/libilbc/slack-desc b/libraries/libilbc/slack-desc
new file mode 100644
index 0000000000..3ed9a29fe8
--- /dev/null
+++ b/libraries/libilbc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+libilbc: libilbc ( iLBC codec from WebRTC )
+libilbc:
+libilbc: iLBC codec from the WebRTC project. It provides a base for
+libilbc: distribution packages and can be used as drop-in replacement for the
+libilbc: non-free code from RFC 3591.
+libilbc:
+libilbc: Homepage: https://github.com/dekkers/libilbc
+libilbc:
+libilbc:
+libilbc:
+libilbc: