summaryrefslogtreecommitdiffstats
path: root/libraries/libreplaygain
diff options
context:
space:
mode:
author Šime Ramov <s@ramov.com>2010-04-19 18:45:04 -0400
committer David Somero <xgizzmo@slackbuilds.org>2010-05-15 10:38:29 +0200
commit576d9d5f4ecacacb61e22a38963c6e1b9b8ec031 (patch)
tree3d0f61b505bf9171bb3779a77971dcb398f158aa /libraries/libreplaygain
parent60b1922cf2297aeb27f9c7c939b25be3a5522c3b (diff)
downloadslackbuilds-576d9d5f4ecacacb61e22a38963c6e1b9b8ec031.tar.gz
slackbuilds-576d9d5f4ecacacb61e22a38963c6e1b9b8ec031.tar.xz
libraries/libreplaygain: Added (Musepack ReplayGain library)
Diffstat (limited to 'libraries/libreplaygain')
-rw-r--r--libraries/libreplaygain/README3
-rw-r--r--libraries/libreplaygain/libreplaygain.SlackBuild67
-rw-r--r--libraries/libreplaygain/libreplaygain.info10
-rw-r--r--libraries/libreplaygain/slack-desc19
4 files changed, 99 insertions, 0 deletions
diff --git a/libraries/libreplaygain/README b/libraries/libreplaygain/README
new file mode 100644
index 0000000000..a7a6efc813
--- /dev/null
+++ b/libraries/libreplaygain/README
@@ -0,0 +1,3 @@
+libreplaygain (Musepack ReplayGain library)
+
+Musepack ReplayGain library.
diff --git a/libraries/libreplaygain/libreplaygain.SlackBuild b/libraries/libreplaygain/libreplaygain.SlackBuild
new file mode 100644
index 0000000000..dbeb3c27a6
--- /dev/null
+++ b/libraries/libreplaygain/libreplaygain.SlackBuild
@@ -0,0 +1,67 @@
+#!/bin/sh
+
+# Slackware build script for libreplaygain
+# Written by Šime Ramov <s@ramov.com>
+
+PRGNAM=libreplaygain
+VERSION=${VERSION:-r453}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xzvf $CWD/$PRGNAM\_$VERSION.tar.gz
+cd $PRGNAM\_$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# adding missing include file to CMakeLists.txt
+echo 'INSTALL(FILES ${libreplaygain_SOURCE_DIR}/include/replaygain/gain_analysis.h DESTINATION include/replaygain)' >> src/CMakeLists.txt
+
+cmake \
+ -G "Unix Makefiles" \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX}
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libreplaygain/libreplaygain.info b/libraries/libreplaygain/libreplaygain.info
new file mode 100644
index 0000000000..26e2353c3f
--- /dev/null
+++ b/libraries/libreplaygain/libreplaygain.info
@@ -0,0 +1,10 @@
+PRGNAM="libreplaygain"
+VERSION="r435"
+HOMEPAGE="http://www.musepack.net/"
+DOWNLOAD="http://files.musepack.net/source/libreplaygain_r453.tar.gz"
+MD5SUM="1bde8f0319fd2a2b9921b2a2dfc47655"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Šime Ramov"
+EMAIL="s@ramov.com"
+APPROVED="dsomero"
diff --git a/libraries/libreplaygain/slack-desc b/libraries/libreplaygain/slack-desc
new file mode 100644
index 0000000000..83905cfaf1
--- /dev/null
+++ b/libraries/libreplaygain/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+libreplaygain: libreplaygain (Musepack ReplayGain library)
+libreplaygain:
+libreplaygain: Musepack ReplayGain library.
+libreplaygain:
+libreplaygain: Homepage: <http://www.musepack.net/>
+libreplaygain:
+libreplaygain:
+libreplaygain:
+libreplaygain:
+libreplaygain:
+libreplaygain: