summaryrefslogtreecommitdiffstats
path: root/libraries/libva
diff options
context:
space:
mode:
author Christopher Reimer <reimer.christopher@freenet.de>2010-09-12 10:56:33 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-09-12 23:08:54 -0500
commitbaf1d03ebc32f0b1e8188d4f0cf504f8cd98ee46 (patch)
treede26b529456759268929bbc4e66f924509ccf76e /libraries/libva
parent009a9a6bb78844351eddffd33cd9ef202419ccb5 (diff)
downloadslackbuilds-baf1d03ebc32f0b1e8188d4f0cf504f8cd98ee46.tar.gz
slackbuilds-baf1d03ebc32f0b1e8188d4f0cf504f8cd98ee46.tar.xz
libraries/libva: Added (Video Acceleration API)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/libva')
-rw-r--r--libraries/libva/README8
-rw-r--r--libraries/libva/libva.SlackBuild112
-rw-r--r--libraries/libva/libva.info10
-rw-r--r--libraries/libva/slack-desc19
4 files changed, 149 insertions, 0 deletions
diff --git a/libraries/libva/README b/libraries/libva/README
new file mode 100644
index 0000000000..ecc7a6927b
--- /dev/null
+++ b/libraries/libva/README
@@ -0,0 +1,8 @@
+The main motivation for VAAPI (Video Acceleration API) is to enable
+hardware accelerated video decode/encode at various entry-points
+(VLD, IDCT, Motion Compensation etc.) for the prevailing coding
+standards today (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and
+VC-1/VMW3). Extending XvMC was considered, but due to its original
+design for MPEG-2 MotionComp only, it made more sense to design an
+interface from scratch that can fully expose the video decode
+capabilities in today's GPUs.
diff --git a/libraries/libva/libva.SlackBuild b/libraries/libva/libva.SlackBuild
new file mode 100644
index 0000000000..05e85c8a5c
--- /dev/null
+++ b/libraries/libva/libva.SlackBuild
@@ -0,0 +1,112 @@
+#!/bin/sh
+
+# Slackware build script for libva
+
+# Written by Christopher Reimer (reimer.christopher@freenet.de)
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libva
+VERSION=0.31.1_1+sds4
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCVERS=${VERSION//_/-}
+BASEVER=$(printf $VERSION | cut -d _ -f1)
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$BASEVER
+tar xvf $CWD/${PRGNAM}_$SRCVERS.tar.gz
+cd $PRGNAM-$BASEVER
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+for p in debian/patches/*.patch; do patch -p1 < $p; done
+
+autoreconf
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-shared \
+ --disable-static \
+ --enable-dummy-driver \
+ --enable-i965-driver \
+ --build=$ARCH-slackware-linux
+
+# configure creates its own libtool, but that libtool seems broken:
+cp -a $(which libtool) .
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat debian/copyright > $PKG/usr/doc/$PRGNAM-$VERSION/copyright.debian
+cat debian/changelog > $PKG/usr/doc/$PRGNAM-$VERSION/changelog.debian
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libva/libva.info b/libraries/libva/libva.info
new file mode 100644
index 0000000000..db7c0defd5
--- /dev/null
+++ b/libraries/libva/libva.info
@@ -0,0 +1,10 @@
+PRGNAM="libva"
+VERSION="0.31.1-1+sds4"
+HOMEPAGE="http://www.splitted-desktop.com/~gbeauchesne/"
+DOWNLOAD="http://www.splitted-desktop.com/~gbeauchesne/libva/libva_0.31.1-1+sds4.tar.gz"
+MD5SUM="4610a0d16d19f25cdf98f0fb1ef5902a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Christopher Reimer"
+EMAIL="reimer.christopher@freenet.de"
+APPROVED="rworkman"
diff --git a/libraries/libva/slack-desc b/libraries/libva/slack-desc
new file mode 100644
index 0000000000..f0e20f7302
--- /dev/null
+++ b/libraries/libva/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libva: libva (Video Acceleration API)
+libva:
+libva: The main motivation for VAAPI (Video Acceleration API) is to enable
+libva: hardware accelerated video decode/encode at various entry-points (VLD,
+libva: IDCT, Motion Compensation etc.) for the prevailing coding standards
+libva: today (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3)
+libva:
+libva: Website: http://www.splitted-desktop.com/~gbeauchesne/
+libva:
+libva:
+libva: