summaryrefslogtreecommitdiffstats
path: root/libraries/libwhisker2
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2010-05-12 23:30:47 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:30:47 +0200
commitba01f403905f5460bf0e3896414f4ae467e49152 (patch)
tree3d407199a335a5e61bb658a5212e6533b805b574 /libraries/libwhisker2
parent00c1d1b9601b9d49ad934fa071ac17f55ae904a7 (diff)
downloadslackbuilds-ba01f403905f5460bf0e3896414f4ae467e49152.tar.gz
slackbuilds-ba01f403905f5460bf0e3896414f4ae467e49152.tar.xz
libraries/libwhisker2: Added to 12.2 repository
Diffstat (limited to 'libraries/libwhisker2')
-rw-r--r--libraries/libwhisker2/Makefiles.patch.gzbin0 -> 1109 bytes
-rw-r--r--libraries/libwhisker2/README8
-rw-r--r--libraries/libwhisker2/libwhisker2.SlackBuild94
-rw-r--r--libraries/libwhisker2/libwhisker2.info8
-rw-r--r--libraries/libwhisker2/slack-desc19
5 files changed, 129 insertions, 0 deletions
diff --git a/libraries/libwhisker2/Makefiles.patch.gz b/libraries/libwhisker2/Makefiles.patch.gz
new file mode 100644
index 0000000000..ad7152c637
--- /dev/null
+++ b/libraries/libwhisker2/Makefiles.patch.gz
Binary files differ
diff --git a/libraries/libwhisker2/README b/libraries/libwhisker2/README
new file mode 100644
index 0000000000..7a4ab1f61e
--- /dev/null
+++ b/libraries/libwhisker2/README
@@ -0,0 +1,8 @@
+What is Libwhisker:
+Libwhisker is a Perl module geared specificly for HTTP testing.
+Libwhisker has a few design principles:
+- Portable: runs with 0 changes on Unix, Windows, etc (100% Perl)
+- Flexible: designed with a 'no rules' approach
+- Contained: designed to not require external modules when possible
+- Localized: does not require installation to use (except for this SlackBuild
+ ;-) )
diff --git a/libraries/libwhisker2/libwhisker2.SlackBuild b/libraries/libwhisker2/libwhisker2.SlackBuild
new file mode 100644
index 0000000000..408cb3a122
--- /dev/null
+++ b/libraries/libwhisker2/libwhisker2.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for libwhisker2
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libwhisker2
+VERSION=2.4
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+DOCS="CHANGES DISTRIBUTION KNOWNBUGS LICENSE README docs scripts"
+
+# Not used at all :-/
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+# Patch Makefiles
+zcat $CWD/Makefiles.patch.gz | patch -p1
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+make lib
+make DESTDIR=$PKG \
+ MAN3PATH=/usr/man/man3 \
+ install
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+( cd $PKG
+ find . \( -name "perllocal.pod" -o -name ".packlist" -o -name "*.bs" \) \
+ -exec rm -f {} \;
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/libwhisker2/libwhisker2.info b/libraries/libwhisker2/libwhisker2.info
new file mode 100644
index 0000000000..947a8ecccb
--- /dev/null
+++ b/libraries/libwhisker2/libwhisker2.info
@@ -0,0 +1,8 @@
+PRGNAM="libwhisker2"
+VERSION="2.4"
+HOMEPAGE="http://www.wiretrip.net/rfp/lw.asp"
+DOWNLOAD="http://downloads.sourceforge.net/whisker/libwhisker2-2.4.tar.gz"
+MD5SUM="bdc618fa52bee38171c12e00bd99e18d"
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/libraries/libwhisker2/slack-desc b/libraries/libwhisker2/slack-desc
new file mode 100644
index 0000000000..bb472dcee7
--- /dev/null
+++ b/libraries/libwhisker2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+libwhisker2: libwhisker2 (perl module)
+libwhisker2:
+libwhisker2: Perl extension geared specificly for HTTP testing.
+libwhisker2:
+libwhisker2:
+libwhisker2:
+libwhisker2:
+libwhisker2:
+libwhisker2:
+libwhisker2:
+libwhisker2: