summaryrefslogtreecommitdiffstats
path: root/libraries/lightblue
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-05-13 00:59:00 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:59:00 +0200
commit9955c8399703ec8532013abc486037f257c95bbe (patch)
treef53e50b7df8095741a527b4ef542ff67c8c83b17 /libraries/lightblue
parent335ed44c91f4e2317651d0756ad239cbe7cd56b4 (diff)
downloadslackbuilds-9955c8399703ec8532013abc486037f257c95bbe.tar.gz
slackbuilds-9955c8399703ec8532013abc486037f257c95bbe.tar.xz
libraries/lightblue: Added to 13.0 repository
Diffstat (limited to 'libraries/lightblue')
-rw-r--r--libraries/lightblue/README5
-rw-r--r--libraries/lightblue/lightblue.SlackBuild61
-rw-r--r--libraries/lightblue/lightblue.info10
-rw-r--r--libraries/lightblue/slack-desc19
4 files changed, 95 insertions, 0 deletions
diff --git a/libraries/lightblue/README b/libraries/lightblue/README
new file mode 100644
index 0000000000..01b11f65eb
--- /dev/null
+++ b/libraries/lightblue/README
@@ -0,0 +1,5 @@
+LightBlue is a cross-platform Bluetooth API for Python which provides
+simple access to Bluetooth operations. It is available for Mac OS X,
+GNU/Linux and Nokia's Python for Series 60 platform for mobile phones.
+
+Lightblue requires pybluez.
diff --git a/libraries/lightblue/lightblue.SlackBuild b/libraries/lightblue/lightblue.SlackBuild
new file mode 100644
index 0000000000..9ab96c9631
--- /dev/null
+++ b/libraries/lightblue/lightblue.SlackBuild
@@ -0,0 +1,61 @@
+#!/bin/sh
+
+# Slackware build script for lightblue
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=lightblue
+VERSION=${VERSION:-0.4}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG COPYING PKG-INFO README.txt doc \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/lightblue/lightblue.info b/libraries/lightblue/lightblue.info
new file mode 100644
index 0000000000..bd4c5d1e26
--- /dev/null
+++ b/libraries/lightblue/lightblue.info
@@ -0,0 +1,10 @@
+PRGNAM="lightblue"
+VERSION="0.4"
+HOMEPAGE="http://lightblue.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/project/lightblue/lightblue/0.4/lightblue-0.4.tar.gz"
+MD5SUM="2f2bf66faa4bf1a79eb28a47584077b7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/libraries/lightblue/slack-desc b/libraries/lightblue/slack-desc
new file mode 100644
index 0000000000..2c29128946
--- /dev/null
+++ b/libraries/lightblue/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+lightblue: lightblue (Cross platform Bluetooth API for Python)
+lightblue:
+lightblue: LightBlue is a cross-platform Bluetooth API for Python which provides
+lightblue: simple access to Bluetooth operations. It is available for Mac OS X,
+lightblue: GNU/Linux and Nokia's Python for Series 60 platform for mobile phones.
+lightblue:
+lightblue: Homepage: http://lightblue.sourceforge.net/
+lightblue:
+lightblue:
+lightblue:
+lightblue: