summaryrefslogtreecommitdiffstats
path: root/libraries/miniupnpc
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2017-03-09 22:56:46 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-03-11 07:04:04 +0700
commitba1c95775cd11e94eaa657446ecd374ddd417953 (patch)
tree70f306505ebe5a8fe430dbfc5bcae52702004eef /libraries/miniupnpc
parentcda10d2e3ad5c06420b75d60477e74beaf3fdc15 (diff)
downloadslackbuilds-ba1c95775cd11e94eaa657446ecd374ddd417953.tar.gz
slackbuilds-ba1c95775cd11e94eaa657446ecd374ddd417953.tar.xz
libraries/miniupnpc: Updated for version 2.0
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'libraries/miniupnpc')
-rw-r--r--libraries/miniupnpc/README7
-rw-r--r--libraries/miniupnpc/miniupnpc.SlackBuild20
-rw-r--r--libraries/miniupnpc/miniupnpc.info6
3 files changed, 18 insertions, 15 deletions
diff --git a/libraries/miniupnpc/README b/libraries/miniupnpc/README
index 702b316b8f..c58769dd2d 100644
--- a/libraries/miniupnpc/README
+++ b/libraries/miniupnpc/README
@@ -2,5 +2,8 @@ MiniUPnPc, the client library, enabling applications to access the
services provided by an UPnP "Internet Gateway Device" present on
the network. In UPnP terminology, it is a UPnP Control Point.
-MiniUPnPc will install a Python3 module if Python3 is installed on
-the system during compile time.
+Optional dependency: python3
+
+Note: To install python 3 bindings set PYTHON3=yes.
+
+ # PYTHON3=yes ./miniupnpc.SlackBuild
diff --git a/libraries/miniupnpc/miniupnpc.SlackBuild b/libraries/miniupnpc/miniupnpc.SlackBuild
index 10f12ab939..6ea8d4b281 100644
--- a/libraries/miniupnpc/miniupnpc.SlackBuild
+++ b/libraries/miniupnpc/miniupnpc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for miniupnpc
-# Copyright 2012-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=miniupnpc
-VERSION=${VERSION:-1.9}
+VERSION=${VERSION:-2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -64,10 +64,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Slackware specific info.
patch -p1 < $CWD/slackware-version.patch
@@ -82,7 +82,7 @@ CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG
# For python 3.x support.
-if `python3 -c 'import distutils' 2>/dev/null`; then
+if [ "${PYTHON3:-no}" == "yes" ]; then
CFLAGS="$SLKCFLAGS" \
python3 setup.py build
python3 setup.py install --root=$PKG
diff --git a/libraries/miniupnpc/miniupnpc.info b/libraries/miniupnpc/miniupnpc.info
index 58003cffb5..b1ea85c929 100644
--- a/libraries/miniupnpc/miniupnpc.info
+++ b/libraries/miniupnpc/miniupnpc.info
@@ -1,8 +1,8 @@
PRGNAM="miniupnpc"
-VERSION="1.9"
+VERSION="2.0"
HOMEPAGE="http://miniupnp.free.fr/"
-DOWNLOAD="http://miniupnp.free.fr/files/miniupnpc-1.9.tar.gz"
-MD5SUM="5ef3ba321e6df72d6519b728b292073e"
+DOWNLOAD="http://miniupnp.free.fr/files/miniupnpc-2.0.tar.gz"
+MD5SUM="2acc4ec912c15447a40cf14ae50df7b9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""