summaryrefslogtreecommitdiffstats
path: root/libraries/mygpoclient
diff options
context:
space:
mode:
author Chris Farrell <timcowchip@gorge.net>2018-01-04 00:12:55 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-01-06 06:55:29 +0700
commit3f9b5fc969255fef9cc41c092ffb8667873e1f66 (patch)
tree15c6798a6eab488faa1cf9023f8a013aef98d8df /libraries/mygpoclient
parentfa33e1a3de4748d0c78ee1b47b9b0ce0e39f7b30 (diff)
downloadslackbuilds-3f9b5fc969255fef9cc41c092ffb8667873e1f66.tar.gz
slackbuilds-3f9b5fc969255fef9cc41c092ffb8667873e1f66.tar.xz
libraries/mygpoclient: Updated for version 1.8.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries/mygpoclient')
-rw-r--r--libraries/mygpoclient/README6
-rw-r--r--libraries/mygpoclient/mygpoclient.SlackBuild16
-rw-r--r--libraries/mygpoclient/mygpoclient.info12
3 files changed, 19 insertions, 15 deletions
diff --git a/libraries/mygpoclient/README b/libraries/mygpoclient/README
index f9993d2166..981cb48f67 100644
--- a/libraries/mygpoclient/README
+++ b/libraries/mygpoclient/README
@@ -1,6 +1,6 @@
-The mygpoclient library allows developers to utilize a Pythonic
+The mygpoclient library allows developers to utilize a Pythonic
interface to the gpodder.net web services.
-Included is an example utility, bpsync, that will will synchronize your
-bp.conf file from BashPodder to the gpodder.net web services, check out
+Included is an example utility, bpsync, that will will synchronize your
+bp.conf file from BashPodder to the gpodder.net web services, check out
http://lincgeek.org/bashpodder for more information.
diff --git a/libraries/mygpoclient/mygpoclient.SlackBuild b/libraries/mygpoclient/mygpoclient.SlackBuild
index cf8b161393..7e9d076ac0 100644
--- a/libraries/mygpoclient/mygpoclient.SlackBuild
+++ b/libraries/mygpoclient/mygpoclient.SlackBuild
@@ -4,14 +4,16 @@
# Written by Luis Henrique <lmello.009@gmail.com>
+# Edited by Chris Farrell <timcowchip@gorge.net>
+
PRGNAM=mygpoclient
-VERSION=${VERSION:-1.6}
+VERSION=${VERSION:-1.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -22,8 +24,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -51,14 +53,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+sed -i -e 's:share/man/man1:man/man1:' setup.py
+
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS COPYING DEPENDENCIES NEWS PKG-INFO README \
+ AUTHORS COPYING NEWS PKG-INFO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/mygpoclient/mygpoclient.info b/libraries/mygpoclient/mygpoclient.info
index 27923a9619..2bb7183e68 100644
--- a/libraries/mygpoclient/mygpoclient.info
+++ b/libraries/mygpoclient/mygpoclient.info
@@ -1,10 +1,10 @@
PRGNAM="mygpoclient"
-VERSION="1.6"
+VERSION="1.8"
HOMEPAGE="https://github.com/gpodder/mygpoclient"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/mygpoclient-1.6.tar.gz"
-MD5SUM="41cb32aea08e2183ea779bec9b456be6"
+DOWNLOAD="https://github.com/timcowchip/DISTFILES/raw/master/mygpoclient-1.8.tar.gz"
+MD5SUM="b2623c5c068ed137a8ce0f18229aaf7a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Luis Henrique"
-EMAIL="lmello.009@gmail.com"
+REQUIRES="python3"
+MAINTAINER="Chris Farrell"
+EMAIL="timcowchip@gorge.net"