summaryrefslogtreecommitdiffstats
path: root/libraries/mysql-connector-c++
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-19 23:26:24 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-19 23:26:24 -0400
commitf9889988276b1fc27efbf565f02198310d53b8e2 (patch)
tree819f204ac2be30a580d1327b315e1ce71b1f4488 /libraries/mysql-connector-c++
parent0947058f30a16a1fa35706bd954be6339e3518d9 (diff)
downloadslackbuilds-f9889988276b1fc27efbf565f02198310d53b8e2.tar.gz
slackbuilds-f9889988276b1fc27efbf565f02198310d53b8e2.tar.xz
libraries/mysql-connector-c++: Fix docs.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries/mysql-connector-c++')
-rw-r--r--libraries/mysql-connector-c++/mysql-connector-c++.SlackBuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/libraries/mysql-connector-c++/mysql-connector-c++.SlackBuild b/libraries/mysql-connector-c++/mysql-connector-c++.SlackBuild
index 2d59c641c1..07765b7b68 100644
--- a/libraries/mysql-connector-c++/mysql-connector-c++.SlackBuild
+++ b/libraries/mysql-connector-c++/mysql-connector-c++.SlackBuild
@@ -22,11 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220419 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - move a couple of doc files from /usr to the actual doc dir.
+# - do not include CMakeLists.txt in the doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mysql-connector-c++
VERSION=${VERSION:-8.0.28}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +76,9 @@ cd $PRGNAM-$VERSION-src
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
mkdir -p build
cd build
@@ -87,15 +88,15 @@ cd build
-DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp *.txt *.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+rm -f CMakeLists.txt # 20220419 bkw: not documentation.
+cp -a *.txt *.md $PKGDOC
+mv $PKG/usr/INFO_* $PKGDOC # 20220419 bkw: this *is* documentation.
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc