summaryrefslogtreecommitdiffstats
path: root/libraries/opal
diff options
context:
space:
mode:
author David Woodfall <dave@dawoodfall.net>2011-09-22 21:19:01 -0300
committer Niels Horn <niels.horn@slackbuilds.org>2011-09-22 21:19:01 -0300
commit9d37cb0ba5765be027786d7db970aa332261d5fd (patch)
treed24b0682a3b8cfacc403d1a1e8170693bf2ee50f /libraries/opal
parentaf7810682850345a22725c9f193868f030a1500f (diff)
downloadslackbuilds-9d37cb0ba5765be027786d7db970aa332261d5fd.tar.gz
slackbuilds-9d37cb0ba5765be027786d7db970aa332261d5fd.tar.xz
libraries/opal: Updated for version 3.6.8 (+new maintainer)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'libraries/opal')
-rw-r--r--libraries/opal/README2
-rw-r--r--libraries/opal/opal-3.6.7-celt-0.7-update.patch103
-rw-r--r--libraries/opal/opal.SlackBuild14
-rw-r--r--libraries/opal/opal.info12
-rw-r--r--libraries/opal/slack-desc1
5 files changed, 13 insertions, 119 deletions
diff --git a/libraries/opal/README b/libraries/opal/README
index 035a8e3b5d..6a7a516728 100644
--- a/libraries/opal/README
+++ b/libraries/opal/README
@@ -5,3 +5,5 @@ networks.
Opal requires ptlib. Speex is also recommended, even though Opal
ships with its own version. x264 and ffmpeg are optional, but
highly recommended, for video support.
+
+Celt is also optional.
diff --git a/libraries/opal/opal-3.6.7-celt-0.7-update.patch b/libraries/opal/opal-3.6.7-celt-0.7-update.patch
deleted file mode 100644
index 045a200810..0000000000
--- a/libraries/opal/opal-3.6.7-celt-0.7-update.patch
+++ /dev/null
@@ -1,103 +0,0 @@
---- a/plugins/audio/celt/celtcodec.c
-+++ b/plugins/audio/celt/celtcodec.c
-@@ -52,7 +52,12 @@ static int init_mode(CELTContext *celt, const struct PluginCodec_Definition * co
- {
- int error = 0;
-
-- celt->mode = celt_mode_create(codec->sampleRate, 1, codec->parm.audio.samplesPerFrame, &error);
-+ celt->mode = celt_mode_create(codec->sampleRate,
-+#if !defined(HAVE_CELT_0_7_0_OR_LATER)
-+ 1,
-+#endif
-+ codec->parm.audio.samplesPerFrame,
-+ &error);
- if (celt->mode == NULL) {
- return FALSE;
- }
-@@ -65,6 +70,9 @@ static int init_mode(CELTContext *celt, const struct PluginCodec_Definition * co
-
- static void * celt_create_encoder(const struct PluginCodec_Definition * codec)
- {
-+#if defined(HAVE_CELT_0_7_0_OR_LATER)
-+ int error = 0;
-+#endif
- CELTContext * celt = malloc(sizeof(CELTContext));
- if (celt == NULL)
- return NULL;
-@@ -73,8 +81,12 @@ static void * celt_create_encoder(const struct PluginCodec_Definition * codec)
- free(celt);
- return NULL;
- }
--
-+
-+#if defined(HAVE_CELT_0_7_0_OR_LATER)
-+ celt->encoder_state = celt_encoder_create(celt->mode, 1, &error);
-+#else
- celt->encoder_state = celt_encoder_create(celt->mode);
-+#endif
- if (celt->encoder_state == NULL ) {
- celt_mode_destroy(celt->mode);
- free(celt);
-@@ -87,6 +99,9 @@ static void * celt_create_encoder(const struct PluginCodec_Definition * codec)
-
- static void * celt_create_decoder(const struct PluginCodec_Definition * codec)
- {
-+#if defined(HAVE_CELT_0_7_0_OR_LATER)
-+ int error = 0;
-+#endif
- CELTContext * celt = malloc(sizeof(CELTContext));
- if (celt == NULL)
- return NULL;
-@@ -96,7 +111,11 @@ static void * celt_create_decoder(const struct PluginCodec_Definition * codec)
- return NULL;
- }
-
-+#if defined(HAVE_CELT_0_7_0_OR_LATER)
-+ celt->decoder_state = celt_decoder_create(celt->mode, 1, &error);
-+#else
- celt->decoder_state = celt_decoder_create(celt->mode);
-+#endif
- if (celt->decoder_state == NULL ) {
- celt_mode_destroy(celt->mode);
- free(celt);
-@@ -142,7 +161,9 @@ static int celt_codec_encoder(const struct PluginCodec_Definition * codec,
- if (*toLen < celt->bytes_per_packet)
- return FALSE;
-
--#ifdef HAVE_CELT_0_5_0_OR_LATER
-+#if defined(HAVE_CELT_0_7_0_OR_LATER)
-+ byteCount = celt_encode(celt->encoder_state, (celt_int16 *)fromPtr, NULL, (char *)toPtr, celt->bytes_per_packet);
-+#elif defined(HAVE_CELT_0_5_0_OR_LATER)
- byteCount = celt_encode(celt->encoder_state, (celt_int16_t *)fromPtr, NULL, (char *)toPtr, celt->bytes_per_packet);
- #else
- byteCount = celt_encode(celt->encoder_state, (celt_int16_t *)fromPtr, (char *)toPtr, celt->bytes_per_packet);
---- a/plugins/configure.ac
-+++ b/plugins/configure.ac
-@@ -313,9 +313,12 @@
- AC_SUBST(CELT_LIBS)
- AC_DEFINE([HAVE_CELT], [1], [celt])
- HAVE_CELT=yes
-- PKG_CHECK_EXISTS([celt >= 0.5.0],
-- [
-- AC_DEFINE([HAVE_CELT_0_5_0_OR_LATER], [1], [celt 0.5.0 or later found])
-+ PKG_CHECK_EXISTS([celt >= 0.7.0], [
-+ AC_DEFINE([HAVE_CELT_0_7_0_OR_LATER], [1], [celt 0.7.0 or later found])
-+ ],
-+ [PKG_CHECK_EXISTS([celt >= 0.5.0], [
-+ AC_DEFINE([HAVE_CELT_0_5_0_OR_LATER], [1], [celt 0.5.0 or later found])
-+ ])
- ])
- ],
- [
---- a/plugins/plugin-config.h.in 2010-02-14 16:07:28.000000000 +0100
-+++ b/plugins/plugin-config.h.in 2010-02-14 16:07:42.000000000 +0100
-@@ -15,6 +15,9 @@
- /* celt 0.5.0 or later found */
- #undef HAVE_CELT_0_5_0_OR_LATER
-
-+/* celt 0.7.0 or later found */
-+#undef HAVE_CELT_0_7_0_OR_LATER
-+
- /* Define to 1 if you have the <dlfcn.h> header file. */
- #undef HAVE_DLFCN_H
-
diff --git a/libraries/opal/opal.SlackBuild b/libraries/opal/opal.SlackBuild
index df06d73f19..8dad0ab26a 100644
--- a/libraries/opal/opal.SlackBuild
+++ b/libraries/opal/opal.SlackBuild
@@ -2,7 +2,9 @@
# Slackware build script for Opal
-# Copyright 2008-2009 Mauro Giachero (mauro dot giachero at gmail dot com)
+# Copyright 2008-2009 Mauro Giachero
+# All rights reserved.
+# Copyright 2011 David Woodfall
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +25,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=opal
-VERSION=${VERSION:-3.6.7}
+VERSION=${VERSION:-3.6.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -70,10 +70,6 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
-# Patch to add celt 0.7 support to opal
-# Found at
-# http://packages.gentoo.org/package/net-libs/opal?arches=fbsd
-patch -p1 < $CWD/opal-3.6.7-celt-0.7-update.patch
(
cd plugins
aclocal
@@ -97,7 +93,7 @@ CXXFLAGS="$SLKCFLAGS" \
--enable-shared \
--build=$ARCH-slackware-linux
-make
+make VERBOSE=1
make install DESTDIR=$PKG
# Remove static library
diff --git a/libraries/opal/opal.info b/libraries/opal/opal.info
index 5e844c9231..ea855992bf 100644
--- a/libraries/opal/opal.info
+++ b/libraries/opal/opal.info
@@ -1,10 +1,10 @@
PRGNAM="opal"
-VERSION="3.6.7"
+VERSION="3.6.8"
HOMEPAGE="http://www.opalvoip.org/"
-DOWNLOAD="http://downloads.sourceforge.net/opalvoip/opal-3.6.7.tar.bz2"
-MD5SUM="bd0601c214a4089e86fbdda6aec8d22b"
+DOWNLOAD="http://downloads.sourceforge.net/opalvoip/opal-3.6.8.tar.bz2"
+MD5SUM="a5f4ddc12c5aa34dc9407fe1daaf0f45"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Mauro Giachero"
-EMAIL="mauro dot giachero at gmail dot com"
-APPROVED="rworkman"
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
+APPROVED="Niels Horn"
diff --git a/libraries/opal/slack-desc b/libraries/opal/slack-desc
index 6cc8f4a6fc..e5258fd32b 100644
--- a/libraries/opal/slack-desc
+++ b/libraries/opal/slack-desc
@@ -4,7 +4,6 @@
# the right side marks the last column you can put a character in. You must make
# exactly 11 lines for the formatting to be correct. It's also customary to
# leave one space after the ':'.
-
|-----handy-ruler------------------------------------------------------|
opal: OPAL (Open Phone Abstraction Library)
opal: