summaryrefslogtreecommitdiffstats
path: root/libraries/physfs
diff options
context:
space:
mode:
author Erik Hanson <erik@slackbuilds.org>2010-05-27 10:34:28 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-06-04 01:07:42 -0500
commite57fb3b233c5240c3337f383186b0c969335eb22 (patch)
tree3fc3978e0074b191a175f051b59c1e2222639e7e /libraries/physfs
parent4e50b73d4d781d4faf2c56c773430ad702cd3637 (diff)
downloadslackbuilds-e57fb3b233c5240c3337f383186b0c969335eb22.tar.gz
slackbuilds-e57fb3b233c5240c3337f383186b0c969335eb22.tar.xz
libraries/physfs: Fixed a syntax error, script cleanup.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'libraries/physfs')
-rw-r--r--libraries/physfs/physfs.SlackBuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/libraries/physfs/physfs.SlackBuild b/libraries/physfs/physfs.SlackBuild
index ed6511f108..5f8294ea8f 100644
--- a/libraries/physfs/physfs.SlackBuild
+++ b/libraries/physfs/physfs.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for physfs
#
-# Copyright 2009 Erik W. Hanson, Minneapolis, MN, USA
+# Copyright 2009-2010 Erik W. Hanson, Minneapolis, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,10 +24,9 @@
PRGNAM=physfs
VERSION=2.0.0
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
@@ -54,17 +53,20 @@ elif [ "$ARCH" = "x86_64" ]; then
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
+fi
+
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
+cd $TMP
rm -rf $PRGNAM-$VERSION
-tar zxvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
-cd $PRGNAM-$VERSION || exit 1
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
-# LIB_SUFFIX is ignored work around it.
+# LIB_SUFFIX is ignored, work around it.
sed -i -e "s|DESTINATION lib|DESTINATION lib${LIBDIRSUFFIX}|g" \
-e "s:-Werror::" \
CMakeLists.txt
@@ -79,17 +81,17 @@ cmake \
-DPHYSFS_INTERNAL_ZLIB=OFF \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX:STRING=${LIBDIRSUFFIX} || exit 1
+ -DLIB_SUFFIX:STRING=${LIBDIRSUFFIX}
-make || exit 1
-make install DESTDIR=$PKG || exit 1
+make
+make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGELOG.txt CREDITS.txt INSTALL.txt LICENSE.txt TODO.txt \
- lzma/LZMA-LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install