summaryrefslogtreecommitdiffstats
path: root/libraries/poco
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2016-05-21 10:39:43 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-05-27 07:23:48 +0700
commitdd88cd1b0a45250cacf47dbdfd37197458e43987 (patch)
treeb2ea96ca92e392fa22e8239706e3c410daf6c090 /libraries/poco
parent875fab5870c032619b95093293d2333ba0b59114 (diff)
downloadslackbuilds-dd88cd1b0a45250cacf47dbdfd37197458e43987.tar.gz
slackbuilds-dd88cd1b0a45250cacf47dbdfd37197458e43987.tar.xz
libraries/poco: Update patch.
Signed-off-by: David Spencer <baildon.research@googlemail.com>
Diffstat (limited to 'libraries/poco')
-rw-r--r--libraries/poco/poco_x64.patch28
1 files changed, 14 insertions, 14 deletions
diff --git a/libraries/poco/poco_x64.patch b/libraries/poco/poco_x64.patch
index aeac7c1b06..40966da0b2 100644
--- a/libraries/poco/poco_x64.patch
+++ b/libraries/poco/poco_x64.patch
@@ -1,22 +1,22 @@
---- poco-1.4.6p2-all/Makefile.original 2014-03-13 14:12:58.141661715 +0700
-+++ poco-1.4.6p2-all/Makefile 2014-03-13 14:14:32.910933057 +0700
-@@ -33,7 +33,7 @@
+--- poco-1.7.3-all/Makefile.original 2016-05-21 10:30:38.468392077 +0100
++++ poco-1.7.3-all/Makefile 2016-05-21 10:31:06.823679098 +0100
+@@ -95,7 +95,7 @@
install: libexecs
mkdir -p $(INSTALLDIR)/include/Poco
- mkdir -p $(INSTALLDIR)/lib
+ mkdir -p $(INSTALLDIR)/lib64
mkdir -p $(INSTALLDIR)/bin
- for comp in $(COMPONENTS) ; do \
+ for comp in $(filter-out $(foreach f,$(OMIT),$f%),$(COMPONENTS)) ; do \
if [ -d "$(POCO_BASE)/$$comp/include" ] ; then \
-@@ -43,8 +43,8 @@
- find $(POCO_BUILD)/$$comp/bin -perm -700 -type f -exec cp -f {} $(INSTALLDIR)/bin \; ; \
- fi ; \
- done
-- find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib \;
-- find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib \;
-+ find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib64 \;
-+ find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib64 \;
+@@ -109,8 +109,8 @@
+ find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "cygPoco*" -type f -exec cp -f {} $(INSTALLDIR)/bin \;
+ find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "cygPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/bin \;
+ endif
+- find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib \;
+- find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib \;
++ find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib64 \;
++ find $(POCO_BUILD)/lib/$(OSNAME)/$(OSARCH) -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib64 \;
- libexecs = Foundation-libexec XML-libexec Util-libexec Net-libexec Crypto-libexec NetSSL_OpenSSL-libexec Data-libexec Data/SQLite-libexec Data/ODBC-libexec Data/MySQL-libexec Zip-libexec PageCompiler-libexec PageCompiler/File2Page-libexec
- tests = Foundation-tests XML-tests Util-tests Net-tests Crypto-tests NetSSL_OpenSSL-tests Data-tests Data/SQLite-tests Data/ODBC-tests Data/MySQL-tests Zip-tests
+ libexecs = Foundation-libexec XML-libexec JSON-libexec Util-libexec Net-libexec Crypto-libexec NetSSL_OpenSSL-libexec Data-libexec Data/SQLite-libexec Data/ODBC-libexec Data/MySQL-libexec MongoDB-libexec Zip-libexec PageCompiler-libexec PageCompiler/File2Page-libexec
+ tests = Foundation-tests XML-tests JSON-tests Util-tests Net-tests Crypto-tests NetSSL_OpenSSL-tests Data-tests Data/SQLite-tests Data/ODBC-tests Data/MySQL-tests MongoDB-tests Zip-tests