summaryrefslogtreecommitdiffstats
path: root/libraries/podofo
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-22 11:06:20 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-22 11:06:20 -0400
commitb39307e0c5552a7c8d0df7fd03c3d3113fcae493 (patch)
tree72726a0f452df7d53e563b3c7f428b462e40b643 /libraries/podofo
parente1c5a8d05831bb43cbc96b4b02c883dfcde9bcea (diff)
downloadslackbuilds-b39307e0c5552a7c8d0df7fd03c3d3113fcae493.tar.gz
slackbuilds-b39307e0c5552a7c8d0df7fd03c3d3113fcae493.tar.xz
libraries/podofo: Fix PRINT_PACKAGE_NAME.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries/podofo')
-rw-r--r--libraries/podofo/podofo.SlackBuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/libraries/podofo/podofo.SlackBuild b/libraries/podofo/podofo.SlackBuild
index a7ee71c0ad..8484a157da 100644
--- a/libraries/podofo/podofo.SlackBuild
+++ b/libraries/podofo/podofo.SlackBuild
@@ -22,22 +22,18 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220422 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix PRINT_PACKAGE_NAME.
+# - remove useless INSTALL from doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=podofo
VERSION=${VERSION:-0.9.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -50,6 +46,11 @@ if [ -z "$ARCH" ]; then
esac
fi
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
@@ -75,9 +76,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
sed -i "s/BINARY_DIR}\/objects\"/BINARY_DIR}\/objects\" || true/" test/TokenizerTest/CMakeLists.txt
@@ -101,17 +102,14 @@ cd build
-DCMAKE_BUILD_TYPE=Release ..
make VERBOSE=1
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd -
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS ChangeLog CODING* CONTRIBUTIONS* COPYING* FAQ* INSTALL README* TODO \
+ AUTHORS ChangeLog CODING* CONTRIBUTIONS* COPYING* FAQ* README* TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild