summaryrefslogtreecommitdiffstats
path: root/libraries/pyOpenSSL
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2010-05-12 23:31:04 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:31:04 +0200
commit8cb87f846db65a35aeb892c21f8d6a638a8efa97 (patch)
tree86bb97ab63e9ee693afb7df8813aa42ffc91a1f8 /libraries/pyOpenSSL
parent1b1d778be69a8301f7a27251ccc9ac5156903f61 (diff)
downloadslackbuilds-8cb87f846db65a35aeb892c21f8d6a638a8efa97.tar.gz
slackbuilds-8cb87f846db65a35aeb892c21f8d6a638a8efa97.tar.xz
libraries/pyOpenSSL: Added to 12.2 repository
Diffstat (limited to 'libraries/pyOpenSSL')
-rw-r--r--libraries/pyOpenSSL/README4
-rw-r--r--libraries/pyOpenSSL/pyOpenSSL.SlackBuild72
-rw-r--r--libraries/pyOpenSSL/pyOpenSSL.info8
-rw-r--r--libraries/pyOpenSSL/slack-desc19
4 files changed, 103 insertions, 0 deletions
diff --git a/libraries/pyOpenSSL/README b/libraries/pyOpenSSL/README
new file mode 100644
index 0000000000..70e1a0d826
--- /dev/null
+++ b/libraries/pyOpenSSL/README
@@ -0,0 +1,4 @@
+Python wrapper around a small subset of the OpenSSL library. Includes:
+X509 Certificates, SSL Context objects, SSL Connection objects using
+Python sockets as transport layer. The Connection object wraps all the
+socket methods and can therefore be used in.
diff --git a/libraries/pyOpenSSL/pyOpenSSL.SlackBuild b/libraries/pyOpenSSL/pyOpenSSL.SlackBuild
new file mode 100644
index 0000000000..b6001ed9b7
--- /dev/null
+++ b/libraries/pyOpenSSL/pyOpenSSL.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for pyOpenSSL.
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyOpenSSL
+VERSION=0.8
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="COPYING PKG-INFO README"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py bdist
+tar zxvf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pyOpenSSL/pyOpenSSL.info b/libraries/pyOpenSSL/pyOpenSSL.info
new file mode 100644
index 0000000000..eae49992d6
--- /dev/null
+++ b/libraries/pyOpenSSL/pyOpenSSL.info
@@ -0,0 +1,8 @@
+PRGNAM="pyOpenSSL"
+VERSION="0.8"
+HOMEPAGE="http://pyopenssl.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pyopenssl/pyOpenSSL-0.8.tar.gz"
+MD5SUM="00377690f224d9e59c833fb0459603f4"
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/libraries/pyOpenSSL/slack-desc b/libraries/pyOpenSSL/slack-desc
new file mode 100644
index 0000000000..02f8c98f76
--- /dev/null
+++ b/libraries/pyOpenSSL/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyOpenSSL: pyOpenSSL (Python wrapper for OpenSSL)
+pyOpenSSL:
+pyOpenSSL: This module is a rather thin wrapper around (a subset of) the OpenSSL
+pyOpenSSL: library. With thin wrapper I mean that a lot of the object methods do
+pyOpenSSL: nothing more than calling a corresponding function in the OpenSSL
+pyOpenSSL: library
+pyOpenSSL:
+pyOpenSSL:
+pyOpenSSL:
+pyOpenSSL:
+pyOpenSSL: