summaryrefslogtreecommitdiffstats
path: root/libraries/pyPdf
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2010-05-12 23:31:05 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:31:05 +0200
commit156e587b271c4aa118dfa66b6af9000a5a5fd2ca (patch)
tree785075c576649b99db9cea51022e70e69045c638 /libraries/pyPdf
parent8cb87f846db65a35aeb892c21f8d6a638a8efa97 (diff)
downloadslackbuilds-156e587b271c4aa118dfa66b6af9000a5a5fd2ca.tar.gz
slackbuilds-156e587b271c4aa118dfa66b6af9000a5a5fd2ca.tar.xz
libraries/pyPdf: Added to 12.2 repository
Diffstat (limited to 'libraries/pyPdf')
-rw-r--r--libraries/pyPdf/README12
-rw-r--r--libraries/pyPdf/pyPdf.SlackBuild72
-rw-r--r--libraries/pyPdf/pyPdf.info8
-rw-r--r--libraries/pyPdf/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/libraries/pyPdf/README b/libraries/pyPdf/README
new file mode 100644
index 0000000000..50e3c592a6
--- /dev/null
+++ b/libraries/pyPdf/README
@@ -0,0 +1,12 @@
+A Pure-Python library built as a PDF toolkit. It is capable of:
+ * extracting document information (title, author, ...),
+ * splitting documents page by page,
+ * merging documents page by page,
+ * cropping pages,
+ * merging multiple pages into a single page,
+ * encrypting and decrypting PDF files.
+
+By being Pure-Python, it should run on any Python platform without any
+dependencies on external libraries. It can also work entirely on StringIO
+objects rather than file streams, allowing for PDF manipulation in memory. It is
+therefore a useful tool for websites that manage or manipulate PDFs.
diff --git a/libraries/pyPdf/pyPdf.SlackBuild b/libraries/pyPdf/pyPdf.SlackBuild
new file mode 100644
index 0000000000..18c0ab16ec
--- /dev/null
+++ b/libraries/pyPdf/pyPdf.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for pyPdf.
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyPdf
+VERSION=1.12
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="PKG-INFO README"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py bdist
+tar zxvf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pyPdf/pyPdf.info b/libraries/pyPdf/pyPdf.info
new file mode 100644
index 0000000000..626fd8e612
--- /dev/null
+++ b/libraries/pyPdf/pyPdf.info
@@ -0,0 +1,8 @@
+PRGNAM="pyPdf"
+VERSION="1.12"
+HOMEPAGE="http://pybrary.net/pyPdf/"
+DOWNLOAD="http://pybrary.net/pyPdf/pyPdf-1.12.tar.gz"
+MD5SUM="7be5f7f4659f64fd194e9eb9a38ad425"
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/libraries/pyPdf/slack-desc b/libraries/pyPdf/slack-desc
new file mode 100644
index 0000000000..5417a1afc3
--- /dev/null
+++ b/libraries/pyPdf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyPdf: pyPdf (Python PDF toolkit)
+pyPdf:
+pyPdf: A Pure-Python library built as a PDF toolkit.
+pyPdf:
+pyPdf:
+pyPdf:
+pyPdf:
+pyPdf:
+pyPdf:
+pyPdf:
+pyPdf: