summaryrefslogtreecommitdiffstats
path: root/libraries/pycurl
diff options
context:
space:
mode:
author grissiom <chaos.proton@gmail.com>2010-05-12 23:31:08 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:31:08 +0200
commitb5aaa1770b660aaa12b39980e6acb29edd91f25f (patch)
tree1ea0efa8d060ccc0115a707380854b97b86429b1 /libraries/pycurl
parent0eda190f4e451ddef4c208488a0d204a3653b6d5 (diff)
downloadslackbuilds-b5aaa1770b660aaa12b39980e6acb29edd91f25f.tar.gz
slackbuilds-b5aaa1770b660aaa12b39980e6acb29edd91f25f.tar.xz
libraries/pycurl: Added to 12.2 repository
Diffstat (limited to 'libraries/pycurl')
-rw-r--r--libraries/pycurl/README19
-rw-r--r--libraries/pycurl/pycurl.SlackBuild61
-rw-r--r--libraries/pycurl/pycurl.info8
-rw-r--r--libraries/pycurl/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/libraries/pycurl/README b/libraries/pycurl/README
new file mode 100644
index 0000000000..f8b0bfb2c3
--- /dev/null
+++ b/libraries/pycurl/README
@@ -0,0 +1,19 @@
+PycURL is a Python interface to libcurl. PycURL can be used to fetch
+objects identified by a URL from a Python program, similar to the urllib
+Python module. PycURL is mature, very fast, and supports a lot of features.
+Overview
+
+ * libcurl is a free and easy-to-use client-side URL transfer library,
+ supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and
+ LDAP. libcurl supports HTTPS certificates, HTTP POST, HTTP PUT,
+ FTP uploading, kerberos, HTTP form based upload, proxies, cookies,
+ user+password authentication, file transfer resume, http proxy tunneling
+ and more!
+
+ * libcurl is highly portable, it builds and works identically on
+ numerous platforms, including Solaris, NetBSD, FreeBSD, OpenBSD,
+ Darwin, HPUX, IRIX, AIX, Tru64, Linux, Windows, Amiga, OS/2, BeOs,
+ Mac OS X, Ultrix, QNX, OpenVMS, RISC OS, Novell NetWare, DOS and more...
+
+ * libcurl is free, thread-safe, IPv6 compatible, feature rich, well
+ supported and fast.
diff --git a/libraries/pycurl/pycurl.SlackBuild b/libraries/pycurl/pycurl.SlackBuild
new file mode 100644
index 0000000000..edbd018153
--- /dev/null
+++ b/libraries/pycurl/pycurl.SlackBuild
@@ -0,0 +1,61 @@
+#!/bin/sh
+
+# Slackware build script for pycurl
+
+# Written by Grissiom chaos.proton@gmail.com
+
+PRGNAM=pycurl
+VERSION=${VERSION:-7.19.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p ${PKG}/usr/doc/$PRGNAM-$VERSION
+mv ${PKG}/usr/share/doc/${PRGNAM}/* -t ${PKG}/usr/doc/$PRGNAM-$VERSION
+rm -rf ${PKG}/usr/share
+
+cp PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pycurl/pycurl.info b/libraries/pycurl/pycurl.info
new file mode 100644
index 0000000000..eaaf49f17c
--- /dev/null
+++ b/libraries/pycurl/pycurl.info
@@ -0,0 +1,8 @@
+PRGNAM="pycurl"
+VERSION="7.19.0"
+HOMEPAGE="http://pycurl.sourceforge.net/"
+DOWNLOAD="http://pycurl.sourceforge.net/download/pycurl-7.19.0.tar.gz"
+MD5SUM="919d58fe37e69fe87ce4534d8b6a1c7b"
+MAINTAINER="grissiom"
+EMAIL="chaos.proton@gmail.com"
+APPROVED="dsomero"
diff --git a/libraries/pycurl/slack-desc b/libraries/pycurl/slack-desc
new file mode 100644
index 0000000000..6d91ef6e87
--- /dev/null
+++ b/libraries/pycurl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pycurl: PycURL (Python interface to libcurl).
+pycurl:
+pycurl: libcurl is a free and easy-to-use client-side URL transfer library,
+pycurl: supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and
+pycurl: LDAP. libcurl supports HTTPS certificates, HTTP POST, HTTP PUT,
+pycurl: FTP uploading, kerberos, HTTP form based upload, proxies, cookies,
+pycurl: user+password authentication, file transfer resume, http proxy
+pycurl: tunneling and more!
+pycurl:
+pycurl: Homepage:http://pycurl.sourceforge.net/
+pycurl: