summaryrefslogtreecommitdiffstats
path: root/libraries/pyfltk
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2010-05-11 20:01:00 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:01:00 +0200
commit928c45769997ccd651e2d92b1003031f711ec2ea (patch)
treea671becb6309d0e31c0c22f5ca6d666d1c10120e /libraries/pyfltk
parent9d089fdab23a1a1877e0dbfb97e22445190ab5aa (diff)
downloadslackbuilds-928c45769997ccd651e2d92b1003031f711ec2ea.tar.gz
slackbuilds-928c45769997ccd651e2d92b1003031f711ec2ea.tar.xz
libraries/pyfltk: Added to 12.0 repository
Diffstat (limited to 'libraries/pyfltk')
-rw-r--r--libraries/pyfltk/README4
-rw-r--r--libraries/pyfltk/pyfltk.SlackBuild82
-rw-r--r--libraries/pyfltk/pyfltk.info8
-rw-r--r--libraries/pyfltk/slack-desc19
4 files changed, 113 insertions, 0 deletions
diff --git a/libraries/pyfltk/README b/libraries/pyfltk/README
new file mode 100644
index 0000000000..6e8639cbcb
--- /dev/null
+++ b/libraries/pyfltk/README
@@ -0,0 +1,4 @@
+PyFLTK provides a convenient wrapper for the FLTK GUI library for use in
+Python programs.
+
+It requires fltk and swig, both of which are available at SlackBuilds.org.
diff --git a/libraries/pyfltk/pyfltk.SlackBuild b/libraries/pyfltk/pyfltk.SlackBuild
new file mode 100644
index 0000000000..8ba9065534
--- /dev/null
+++ b/libraries/pyfltk/pyfltk.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+
+# Slackware build script for pyfltk
+
+# Copyright 2006 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Exit on most errors
+set -e
+
+PRGNAM=pyfltk
+SRC_PRGNAM=pyFltk
+VERSION=1.1.2
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="CHANGES PKG-INFO INSTALL TODO COPYING README"
+# html files and python test examples are now located in fltk/ subdirectory
+HTMLDOCS="fltk/docs/*"
+TESTFILES="fltk/test/*"
+
+# SLKCFLAGS are not necessary, it builds using fltk-config flags
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
+cd $SRC_PRGNAM-$VERSION
+chown -R root:root . || true
+chmod -R u+w,go+r-w,a-s .
+
+# Copy documentation files
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Move html files and python test examples in order to preserve and install them
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/{docs,test}
+mv $HTMLDOCS $PKG/usr/doc/$PRGNAM-$VERSION/docs/
+mv $TESTFILES $PKG/usr/doc/$PRGNAM-$VERSION/test/
+
+# build from swig interface files
+cd python
+# FLTK_HOME= is not necessary anymore (include directory auto-detected)
+python ./MakeSwig.py
+
+cd $TMP/$SRC_PRGNAM-$VERSION
+python setup.py build
+# --install-data= flag is ignored now
+python setup.py install --prefix=/usr/ --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pyfltk/pyfltk.info b/libraries/pyfltk/pyfltk.info
new file mode 100644
index 0000000000..8a19d47dcc
--- /dev/null
+++ b/libraries/pyfltk/pyfltk.info
@@ -0,0 +1,8 @@
+PRGNAM="pyfltk"
+VERSION="1.1.2"
+HOMEPAGE="http://pyfltk.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pyfltk/pyFltk-1.1.2.tar.gz"
+MD5SUM="769efe632d3f49f17f6f39383e9023bb"
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="rworkman"
diff --git a/libraries/pyfltk/slack-desc b/libraries/pyfltk/slack-desc
new file mode 100644
index 0000000000..ccad433573
--- /dev/null
+++ b/libraries/pyfltk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyfltk: pyfltk (FLTK Bindings for Python)
+pyfltk:
+pyfltk: PyFLTK provides a convenient wrapper for the FLTK GUI library
+pyfltk: for use in Python programs. It is written by Andreas Held.
+pyfltk:
+pyfltk: http://pyfltk.sf.net/
+pyfltk:
+pyfltk:
+pyfltk:
+pyfltk:
+pyfltk: